Connections to extension numbers outside of internal network

Free PBX and Asterisk on an old laptop with just a CentOS installation.

X-Lite Softphone.
Dynamic IP with DynDNS configured on my Sky Router.

Have looked for and researched and read any articles I can find without joy.
I have not followed the security changes this article recommends but I have read it:


I am having an issue with extensions outside my internal network not connecting. Error: “account failed to enable”

This is not an issue with X-Lite itself (maybe the config of it)as i’m using it on the internal network fine.

X-Lite configuration:

Send Outbound via domain instead of proxy
Register with domain and receive calls - ticked.
Dialplan - #1\a\a.T;match=1;prestrip=2;

Port Forwarding

Port forwarding set up detailed in this screenshot -

Asterisk SIP Settings in FreePBX GUI

Detailed here -

Extension Settings for the specific extension set up for the test (Sorry about the number of image files they are screenshots of the same extension number)

Page 1 -
Page 2 -
Page 3 -
Page 4 -
Page 5 -

----Script whilst my friend tried to connect outside of internal network—

(I can’t see anything obvious here except it keeps saying “Reliably Transmitting (no NAT) to” is the No Nat anything to do with it??) I did try turning it on in the actual extension setting in the GUI but she could still not connect).

here’s the file -

—Other things I have done—

  1. I tried changing the NAT to “Yes” - that didn’t make any difference (within FreePBX Gui)

  2. I tried changing to “Peer” instead of “Friend” - that didn’t work either. (Within the same GUI)

  3. I tried both 1 and 2 together.

  4. I originally tried with both 1) (NAT Default Setting)and 2) friend default setting. (within the GUI)

  5. I restarted Asterisk after I added the extension number and I have saved the extension and hit reply.

  6. I have tried asking my friend to connect with my dynamic IP Address rather than the dyndns address.

—SIP Show Peer for the test Extension xx----

Important note: I have not edited any files from the Linux Command Line - Just made changes within the FreePBX GUI.

—Other information—

After a while no “feedback” was given in the CLI when she tried to connect - it was as if she hadn’t. The IP was still correct however.

I have also been advised that I shouldn’t change any of the settings directly within the text files on the Linux Box - in the past I have done that following youtube videos and the files have saved, i’ve reopened them once, the contents are there and then on the third occasion (sometimes more occasions with the text there) it all disappears and comes up as a blank file even though the file name is correct.

One video advised me to delete all the contents of the sip.conf and extensions.conf file and type in the DialPlan myself in the extensions.conf and also type in the [general] and login details for each user - this information quickly disappeared after having opened the file on a number of occasions to refer to. I had been using VIM and Nano and the same thing happened.

I am hesitant to make changes to files directly on the linux box because of this as the contents may go walkies.
Any assistance would be very gratefully received.
Thanks and Kind Regards,

and have you defined the external ip address and local nets in the sip settings?

Hello bksales, thanks for the reply. I mean’t to update this last night, the issue was actually the port numbers were wrong in my router! Never would have thought to check as someone gave me the wrong port numbers in the first place!!!