External phones unreachable when local network defined

Problem: I noticed that the local network wasn’t defined in Asterisk SIP Settings so I plugged in and all the external extensions immediately dropped offline as soon as I hit Save. I deleted the info and saved again and they came right back up. I tried adding each subnet separately and got the same result.

Background: There are three locations; one in CA where the PBX is (registering from, one in TX that uses a VPN connection (, and an office in Brazil that also has a VPN ( but the employees there often times work from home and register externally with Xlite softphones. I checked and all the external phones have NAT set to yes, there is nothing in the permit/deny fields, and nothing has been changed in the various files that sip.conf includes.

(possibly) Relevant info:
PBX Firmware: 5.211.65-6
Centos 6.5
Asterisk 11.7.0

Any ideas?

Ironically I found this post that I had replied to but this is a different issue since the phones register and work just fine so long as there is no internal network defined:

Please describe your network architecture. In particular, do the affected workstations have a VPN connection? Split tunneling? Hardware VPN at the teleworker sites? If so, how configured? Subnet of affected workstations? X-Lite’s proxy address set to your public IP, or to 10.14.x.x? NAT traversal setting in X-Lite?

Does Asterisk have more than one NIC? If so, how configured? If not, is External IP set correctly?