FreePBX | Register | Issues | Wiki | Portal | Support

Connecting FXS Port to Legacy Analog Overhead Paging System - Questions


(Cameron Rodseth) #1

I’m attempting to connect an FXS port to our existing analog 1 zone paging system.

Here’s where I’m at…

FXS port out to amplifier. Created a DAHDI extension 500 that uses that FXS port. Also created a paging group 502 that includes only extension 500. When I call extension 500, it just rings. The intercom actually plays the ringing, followed by some old AOL type computer speak. When I call 502, I get a beep as if you can make your announcement. Ringing plays over the intercom still.

Do I need a paging gateway? I was hoping I could set the 500 extension to auto-answer, and then the paging system would magically work. However, auto-answer doesn’t do anything…just ringing, which then plays over the intercom. Please advise. If I need a paging gateway, I’ll get one, but I’m surprised the ringing plays over the intercom.

Thank you for any and all assistance.


#2

You need to look at your paging device’s user manual and understand wha type of connection it is expecting.


(Cameron Rodseth) #3

Thank you. I did so and it’s just a dumb amplifier. I checked our old pbx and it refers to that connection as a pickup line. So maybe I need an FXO port instead. Is there a way to pick up a trunk with no call coming in?


(Greg) #4

You would need your dialplan to “auto answer” that extension, I would think, so that the talk pathway starts to the amplifier.

I’m surprised though that you don’t just go out of a sound card to the amplifier… I thought there was a way to do that. I may be mistaken.


(Greg) #5

Hmmm… in looking at paging setup, I have it on an FXS port… nothing special… just programmed it as an extension (in my case, extension 1050).


#6

You need to be very careful because if your paging device has an FXS port and is expecting an FXO on the other side and you connected it to an FXS, then you probably fried both ports, the one on the paging device and the one on freepbx.


(Cameron Rodseth) #7

This is exactly what I tried initially, but I’m not getting any audio to go through, just ringing, which as I said actually plays over the loudspeaker. Do you have auto-answer set in extension options? I tried every setting I could think of in there, but to no avail.


(Cameron Rodseth) #8

The amp literally has two wire connections for an analog phone line. Seems like whatever I feed to the amp will be fine, but right now I’m just feeding it a ringing sound, which is what happens when I dial that extension.


(Greg) #9

What is the make and model of the amp? Perhaps I can look up the manual and give you additional help.


(Cameron Rodseth) #10

It’s a Wheellock AA-100. Very old, older than I’ve been at my job.


(Cameron Rodseth) #11

Oops…one L. Wheelock AA-100.


#12

You first need to make completely sure if it expects an FXO or an FXS on the PBX side.
That is important not only to make it work, but to make sure you don’t fry the ports.
Once you do that, then you configure the way of paging.


(Cameron Rodseth) #13

Agreed, and still researching. Logically, one would think it should be FXS on the pbx side, but I’m still digging.


(Dave Burgess) #14

If the unit has been working with the setup till now, we should be able to reasonably assume that it was working before.

If you dial extension 500, then it works. You indicated that you didn’t set this up originally; is it possible that there is already a custom context that handles your input when you dial 500?

The way to check is to log into the console and “grep 500 /etc/asterisk/extension*”. My guess is that you will find that someone has written up the box to bridge your call and extension 500 together so that all you need is the amp to say whatever is sent to it.

I’m sure there’s a custom way to do this, and maybe someone like @tm1000 might be able to expand on what the Paging module (either the included one or the commercial one) would be able to do to help us…


(Cameron Rodseth) #15

Thanks Dave. I should clarify…

I am setting up a new Freepbx system, and attempting to reuse the existing legacy overhead speaker system that is currently attached to our old pbx. I’ve disconnected the amp from the current pbx, and attached it to port 3 which is an fxs port, assigned to extension 500. When I dial extension 500, it just rings. The ring is then reproduced over the loudspeaker. What I need (I think) is for that extension to auto-answer somehow (the amp won’t do this, I need to somehow force it on the Freepbx side).

I apologize if I’m confusing people, I’m a Freepbx noob.


(Dave Burgess) #16

Don’t worry - we’re tracking what you are asking for.

In the old PBX (assuming its Asterisk based) there was probably a little snippet of custom code that helped your autoanswer the phone. Note that there’s nothing in the extension set up (that I’m aware of) that will assume the phone is answering the call, so asking for that over and over isn’t going to get us anywhere.

Things you can try include:

  • Define it in “Paging and Intercom”, since this module deals with devices that don’t actually try to ring.
  • Set up a custom context that joins your ringing extension to the extension you set up as the page and access it through a feature code.
  • Look at the configuration of the device in the old PBX and see what you can find that might be a custom setting.
  • Look in the configuration files for the old PBX and see if there’s a custom context already set up that handles the “extension” and set up a similar bit of context code to do the same thing.

We’re with you on this, but so far you haven’t posted anything from /var/log/asterisk/full telling us what the phone is actually doing in the two scenarios you posted about. With log information, we could glean why one is working and one isn’t, and recommend a course of action. Honestly, so far most of your posts have seemed like “Nope - try again” posts, and those don’t usually get a lot of support after the first couple tries.

Show us some log information (especially for the scenario that works) and we should be able to narrow the scope of the problem considerably.


(Greg) #17

TELEPHONE: Connect telephone wires to the input screw terminals marked TIP and RING. Set TEL/MIC 1 Switch to TEL position. For connection to unused CO trunk port, see Figure 7. For connection to CO line, Centrex line or Analog
Station port, a Wheelock TPI-100 Interface is required.

Soooo… those manuals kind of stink. Meanwhile, the Tip/Ring (from what I’m seeing), looks like it’s just looking for signal over a UTP pair. The TPI-100 interface seems to be what “answers” and then converts to audio for the phone input. If you have a TPI-100, just make sure it’s on “TEL” instead of mic 1 (and don’t have anything plugged into mic 1)

Hope this is helpful…


(Greg) #18

It looks like it’s a 600ohm input, meaning it would never loop to go “off hook” and answer.

It’s just looking for audio input…

You could have some sort of multicast receiver on the amp (that would be one way)
Otherwise, it’s going to take some sort of box to “answer”, or it needs to just have audio on the port… no voltage (other that 1v signal)… but not “battery” (so not an FXS port)…


(Cameron Rodseth) #19

Thank you Dave. Unfortunately, the old system is an ancient Merlin Magix PBX, of which I know about as much as I do Freepbx :slight_smile: I will keep researching / experimenting.

I’m not opposed to buying a paging gateway or something similar. I AM opposed to replacing the analog speakers / amp if at all possible. I’ve had electricians pull 3 miles of cat6 to transition over to IP based phones. I’d prefer not to force them to replace the old speaker wire as well.


(Dave Burgess) #20

Greg answered your question - the TPI-100 interface (which may already be in place) is your magic bullet. Sounds like it should know exactly what to do.