FreePBX | Register | Issues | Wiki | Portal | Support

Confirm Call on Ring-group fails when Ringing Extension with Follow Me


(Matthew Jensen) #1

I’ve been banging my head against the wall all day on this. I’m trying to send a call through a ring group with confirm call enabled. And from there to an extension with follow me enabled. I don’t want confirm call to be on for all of the follow me calls, on the ones that come from the ring group. But any time I send a call to the extension with confirm enabled on the ring group, as soon as I press 1, I get the “I’m sorry, the incoming call is no longer available or has been answered elsewhere.”

I’m running asterisk 16.3.0, my followme and ringgroups modules are both updated.

Confirm call does seem to work when putting the external number in the ring group, or by dialing the extension with follow me. The problems happens when you put an extension with an external number in follow me in the ring group.

Here’s a snippet.

Executing [s@macro-confirm:1] Set("Local/200@from-internal-00000009;1", "LOOPCOUNT=0") in new stack
-- Executing [s@macro-confirm:2] Set("Local/200@from-internal-00000009;1", "__MACRO_RESULT=ABORT") in new stack
-- Executing [s@macro-confirm:3] NoOp("Local/200@from-internal-00000009;1", " and arv= ") in new stack
-- Executing [s@macro-confirm:4] ExecIf("Local/200@from-internal-00000009;1", "0?Set(ARG1=)") in new stack
-- Executing [s@macro-confirm:5] ExecIf("Local/200@from-internal-00000009;1", "0?Set(ALT_CONFIRM_MSG=)") in new stack
-- Executing [s@macro-confirm:6] Set("Local/200@from-internal-00000009;1", "MSG1=incoming-call-1-accept-2-decline") in new stack
-- Executing [s@macro-confirm:7] BackGround("Local/200@from-internal-00000009;1", "incoming-call-1-accept-2-decline,m,en,macro-confirm") in new stack
-- <Local/200@from-internal-00000009;1> Playing 'incoming-call-1-accept-2-decline.slin' (language 'en')
-- Channel Local/8638000311@from-internal-0000000a;1 joined 'simple_bridge' basic-bridge <1f83ae38-9b44-429c-9bf4-fb49ba05af9c>
-- Channel Local/200@from-internal-00000009;2 joined 'simple_bridge' basic-bridge <1f83ae38-9b44-429c-9bf4-fb49ba05af9c>
-- Channel PJSIP/Voipms-0000000b joined 'simple_bridge' basic-bridge <c5eeca15-d631-4339-a701-784d9ebdc318>
   > 0x7fea403805f0 -- Strict RTP switching to RTP target address 162.254.144.173:14832 as source
-- Channel Local/8638000311@from-internal-0000000a;2 joined 'simple_bridge' basic-bridge <c5eeca15-d631-4339-a701-784d9ebdc318>
-- Executing [1@macro-confirm:1] GotoIf("Local/200@from-internal-00000009;1", "1?toolate,1") in new stack
-- Goto (macro-confirm,toolate,1)
-- Executing [toolate@macro-confirm:1] Set("Local/200@from-internal-00000009;1", "MSG2="incoming-call-no-longer-avail"") in new stack
-- Executing [toolate@macro-confirm:2] Playback("Local/200@from-internal-00000009;1", ""incoming-call-no-longer-avail"") in new stack
-- <Local/200@from-internal-00000009;1> Playing 'incoming-call-no-longer-avail.slin' (language 'en')

Edit: I was able to reproduce this on another server with up-to-date modules and running asterisk 16.3.0. But when testing on a server with only the ringgroups and followme modules updates, I didn’t encounter this problem. Maybe it’s due to a combination of those three things?


(Antivirus6613) #2

I’m experiencing the same thing.

When calling a ring group, follow me will work, but you cannot confirm the call. It will play the too late message.

Running Asterisk 13.26.0 with the latest updates on all modules.


(Matthew Jensen) #3

Here is a link to the bug report.
https://issues.freepbx.org/browse/FREEPBX-19796

It looks like they’ve solved the problem, but it doesn’t appear to be in the latest release of the core module. I’m assuming it will become available soon.


(Lorne Gaetz) #4

That report is a duplicate of this:
https://issues.freepbx.org/browse/FREEPBX-19520

Marked as fixed in core v14.0.25.2 and v15.0.9.26


(Matthew Jensen) #5

I could be totally wrong here, but I’m pretty sure that those are two different problems. Maybe they were similar enough to be put together? I’m definitely still encountering the problem in core 14.0.25.4.

Maybe the changes from 14.0.25.2 caused the problem?


Queue with FollowMe - Too Late. Bug?
(Matthew Jensen) #6

Just to clarify, if you take a look at the description of the report you posted, it describes a problem where the “too-late” message is not played.

If you look at report I posted, you’ll see it describes the opposite. It describes how when a call is sent from a queue (or a ringgroup) to an extension with follow me, the “too-late” announcement is always played. I suspect this is a side effect of the fix for the initial bug. In the bug report, it appears that work was being done to fix it, but then it got marked as a duplicate for some reason.


(Itzik) #7

Fixed in core 14.0.28.11

Upgrade core to edge

fwconsole ma upgrade core --edge

or

fwconsole ma downloadinstall core --tag=14.0.28.11

(Matthew Jensen) #8

Thanks for letting me know about the update, unfortunately, I just tried and it still doesn’t seem to work. I’m on 14.0.28.11, and I still the too-late message when trying to press 1 to confirm a call. Is it possible the fix implemented was for the Queue/follow me bug, rather than the ring group/follow me bug?


(Itzik) #9

I am on Asterisk 13, could be there’s a difference how the confirm calls works in 16.

For the sake of testing, can try to reproduce this with a queue?


(Tom Ray) #10

So what is the Ring Group ring timer set to? As well, what are the FollowMe settings on an extension that is having this issue? Pre Ring, Ring Time, Strategy?


(Matthew Jensen) #11

Ring group:
Ring timer is 35
Ring Strategy: “ringall”
Confirm Calls: Yes
Remote Announce: a custom recording I have

Follow Me on extension:
Pre Ring: 0
Ring Timer: 39
Strategy: “ringall”
Confirm Calls: No

It probably doesn’t make sense to have a longer ring time on the follow me, but I want the ring group to expire first.


(Matthew Jensen) #12

I’ll try to test with the queue when I have a few more minutes to spare.


(Tom Ray) #13

Alright, now can you show a whole call? I’m curious about something and I want to see all the channels that are being created from the RG down to the FM.


(Matthew Jensen) #14

Here is a pastebin url with the call details: https://pastebin.freepbx.org/view/09042f58

I cut out a bit of stuff to keep it from being so long, but I doubt any of it was important for what you were trying to see.


(Matthew Jensen) #15

I’ve never worked with queues, but I didn’t think it would be too complicated. However, I can’t get a queue to ring through to an extension with follow me. I do have the agent restriction set to “call as dialed” but that doesn’t seem to solve the problem. So I can’t tell if the same problem is occurring with my queues.


(Itzik) #16

Do you have any custom stuff in extensions_custom.conf ?


(Matthew Jensen) #17

I do. I have a few things, but the one that could potentially be causing a problem is a blacklist program I have that alerts me if a call is made to a number on a blacklist. These numbers are known for being called when a system is compromised, so I want to be alerted right away.

Could that potentially impact the queue from calling external numbers?