Configure pri trunk from tatateleservices

I am trying to configure PRI line from Tatateleservices from india.
I would like to know what are the settings i need to use for PRI line. The hardware interface is Digium 2 span 1TE235BF model. the device is listed as Two (2) span digital T1/E1/J1/PRI PCI-Express x1 card and hardware echo cancellation (VPM064) in freepbx.
Help needed on this.

You have to ask your provider to tell you the specifics of their PRI connection in order to configure it correctly.

We had a old asterisk server with single port card, if i insert the tatateleservices line to it. It is working.
This indicates line is okay. How to we configure the line now.

If you already had it configured on a single port card, just use the same configuration for the new card, but assign it to one of the two ports, which are called spans in the configuration manuals.

That’s true can i edit the files created by freepbx gui.
Which are the files to be edited for configuring the digium card.

DAHDI files can be edited manually, as long as you don’t have the DAHDI module installed, or you turn off file modification if the module is installed.

How to turnoff DAHDI module


I would like to configure in E1 mode with 30 channels.

You can disable dahdi file writing on advanced settings or if you don’t need the module at all you can uninstall it.

i removed the dahdi config by running
#fwconsole ma delete dahdiconfig

After that i cannot see dahdi confi in freeppx gui.

-> dahdi show status
shows frame and coding as - ESF and BDZS

i would like to change this to ccs,hdb3

the system.conf file contents are


loadzone = us
defaultzone = us

is this correct .

You should be able to use the same config that you had on the old card, by copying and pasting from the old server to the new server.

But framing and coding is not getting changed. Which file tells the asterisk pri details.

I would suggest you start from scratch

You have two spans so the b-channels and d-channels will start at 1 for span1 and at 31 for span 2 I suspect you are using euroisdn

it is unlikely that the loadzone and default zone are US because you are in IN not US , just do it the old fashioned way, and don’t use any ‘helpers’

In general, system.conf and dahdi_channels.conf

since the same line is working in another asterisk server. there the zone is set to us

I bet it sounds the tones sound strange. Do you not still use UK tones in India?

yes, we use ‘us’ in old server and the same server is working fine with this new line without any changes.

when i run

-> dahdi show status

Description Alarms IRQ bpviol CRC Fra Codi O ptions LBO
WCTE23X (PCI) Card 0 Span 1 UNCONFI 0 0 0 CAS Unk 0 db (CSU)/0-133 feet (DSX-1)
WCTE23X (PCI) Card 0 Span 2 UNCONFI 0 0 0 CAS Unk 0 db (CSU)/0-133 feet (DSX-1)

here the line shows alaram shows UNCONGI, Coding is Unk
Why it that , that the configuration set in system.conf is not reflecting here.

Have you reloaded dahdi and asterisk?

when i run
/etc/init.d/dahdi restart
it gives me an error as below
Restarting dahdi (via systemctl): Job for dahdi.service failed because the control process exited with error code. See “systemctl status dahdi.service” and “journalctl -xe” for details.

when i run
systemctl status dahdi.service
it gave me
● dahdi.service - LSB: DAHDI kernel modules
Loaded: loaded (/etc/rc.d/init.d/dahdi; bad; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2018-06-20 12:48:06 UTC; 1min 12s ago
Docs: man:systemd-sysv-generator(8)
Process: 15450 ExecStart=/etc/rc.d/init.d/dahdi start (code=exited, status=1/FAILURE)

Jun 20 12:48:06 freepbx.sangoma.local dahdi[15450]: wctc4xxp: [ OK ]
Jun 20 12:48:06 freepbx.sangoma.local dahdi[15450]: xpp_usb: [ OK ]
Jun 20 12:48:06 freepbx.sangoma.local dahdi[15450]: D: auto ‘/sys/bus/dahdi_devices/devices/pci:0000:01:00.0’
Jun 20 12:48:06 freepbx.sangoma.local dahdi[15450]: auto-assign /sys/bus/dahdi_devices/devices/pci:0000:01:00.0
Jun 20 12:48:06 freepbx.sangoma.local dahdi[15450]: Running dahdi_cfg: DAHDI_SPANCONFIG failed on span 1: Invalid argument (22)
Jun 20 12:48:06 freepbx.sangoma.local dahdi[15450]: [FAILED]
Jun 20 12:48:06 freepbx.sangoma.local systemd[1]: dahdi.service: control process exited, code=exited status=1
Jun 20 12:48:06 freepbx.sangoma.local systemd[1]: Failed to start LSB: DAHDI kernel modules.
Jun 20 12:48:06 freepbx.sangoma.local systemd[1]: Unit dahdi.service entered failed state.
Jun 20 12:48:06 freepbx.sangoma.local systemd[1]: dahdi.service failed.