Configure Grandstream HT813 for UK use freepbx


(Ralph) #1

I have been using a SPA232d for POTS to freepbx with no problems. The spa unit is now very noisy and unreliable so I have purchased a Grandstream HT813 to use only the fxo connection. I have setup a chanpjsip trunk which is shown as registered by freepbx and available. Calls do not connect in or out.
I have changed the dial tones and other tones to what I found as UK values but I am stumped by current problem.
Does anyone have any experience of this device with freepbx especially if any UK user can assist.
Many thanks

Ralph


(Ralph) #2

I have now been able to pass incoming calls to freepbx by activating the fxs port account which I do not intend to use. According to the manual this should not be necessary.
However I am unable to pass outgoing calls. I can not delete the pstn passcode of *00 and keep it empty (on reboot default replaces) so have replaced with single digit added as prepend to outgoing route.
A phone plugged in to fxs port also only receives but can not make calls.
Any help gratefully received
Ralph


(James) #3

I do have the HT813 working with incoming and outgoing calls in the UK, but only on chansip. I haven’t tried pjsip as the number on the line is going to be moved to voip at the end of the contract.


(Ralph) #4

My problems I dont think are with the sip side as the device is registered with my pbx and incoming works.
Can you share your settings with me as I feel the problem is with the ht813 connecting with the line out of fxo port.
Thanks very much


#5

Assuming that you have Stage Method set to 1, and the Dial Plan permits and does not alter the number dialed, then whatever number is sent from the trunk should be dialed on the FXO port.

As a start, at the Asterisk command prompt, type
pjsip set logger on
make a failing outbound test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here. It would also be useful to post screenshots of the FXO Port page.


(Ralph) #6

Stewart1 thanks for rsponse. Will do screenshots and log.
What or where is Stage Method?


#7

See http://www.grandstream.com/sites/default/files/Resources/HT813_Administration_Guide.pdf
p. 70


(James) #8

Here’s what I have:
(I’ve changed a few so i’m not posting my numbers/secrets)

FreePBX Trunk sip settings:
Trunk name on the sipsettings, outgoing tab must be the same as username below.
username=012345678910
type=peer
secret=ht813
qualify=yes
port=5062 (this is the same as set on HT813)
host=dynamic
dtmfmode=rfc2833
disallow=all
context=from-trunk
allow=ulaw

On HT813 :
Basic settings:
Unconditional call forward to voip:
User ID: 012345678910
SIP Server: 192.168.1.100
Port: 5160 (Chan Sip Port in freepbx)

FXO port settings:
Account active: yes
Primary sip server: 192.168.1.100:5160
Outbound proxy: 192.168.1.100:5160
SIP User id: 012345678910
Authenicate id: 012345678910
password: ht813 (whatever you set above in freepbx)
Sip registration: yes
outgoing call without registration: yes
local sip port: 5062 (just make sure its the same as in freepbx trunk settings)
caller id scheme: sin227-bt

Those are my settings and I have it working, apart from disconnect detection. The trunk name in sip settings must be the same as username/user id. I had a few issues with call quality on the newer firmware so i rolled back to 1.0.0.8 and its been fine since.


(Ralph) #9

Thanks very much. I have the same settings as you except the port which I have set 5060 for pjsip.
So unable to call out still but grateful for your time and interest.


(Ralph) #10

Thanks I have solved the issue with your reference to Stage Method set to 1. I had 2 and that what the only difference between working and not working.

Many thanks to you and James for assistance.


(United Kingdom) #11

Hi Ralph.
I have a HT813, I am having lots of issues in setting up the FXO port to ring the FXS port on a BT Line, it rings, but I get an engaged tone on pick up and the same if trying to dial out, I believe it the is all the line settings that are wrong.
Would you possibly be able to send your settings used for the advanced, FXS and FXO ports on your HT813 please, it would be greatly appreciated.
I have tried settings from here [UK Regional Settings for Grandstream telephone adaptors on the ukvoipforums
I can configure it to work with FreePBX ok, just struggling with BT as usual :slight_smile:
Thanks in advance.
Jon


(Ralph) #12

Hi Jon,

Will supply settings as screenshots over the next couple of days. I will try and do this before Xmas day but it maybe Saturday if I run out of time.
Can you confirm that your freepbx can see the trunk, check in reports that this is the case. I do not use a phone on fxs socket so have that set to off but my fxo settings work fine incoming and outgoing.
Ralph


(United Kingdom) #13

Hi Ralph.
Many thanks for the reply much appreciated.
Screen shots will be great, means I shouldn’t get it wrong:)
I have registered the trunk and extension on the pbx and all seems ok, it shows as online and I can make calls to and from the FXS port from the PBX, I just cant quite get the FXO side to work for me, if I call the POTS line the phone attached tot the FXS port rings, but picking up the handset does not answer the call.
Thanks again and Merry Christmas

Jon

Th


(Ralph) #14

Picture1 Picture2 Picture3 Picture4 Picture5 Picture6 Picture7 Picture8


(Ralph) #15

Picture9 Picture10 Picture11 Picture12 Picture13 Picture14 Picture15 Picture16 Picture17 Picture18 Picture19 Picture20 Picture21


(Ralph) #16

Hi Jon,
Hope you can enlarge these.
Most important check Stage Dialing set to 1, defaults to 2
Ring and other tones are BT standards

Ralph


(United Kingdom) #17

Hi Ralph.
Thank you very much, absolutely spot on :unfortunately a little to small to make out the text.
Is there a way to send you a private message with my email address?
Thanks again for your assistance and very rapid replies and have a fantastic Christmas.

Hi Ralph.
Struggling with the BT line settings, would you possible be able to post those pages a bit bigger please, or is there a link to a webpage with the settings please.

Hi Ralph

Thanks again for your reply.
Sorry I cant reply, as new post limit reached, so have to modify.
The scenario you have is the one I am trying to achieve, with possibly the FXS port being able to ring as well, but not a priority.
Thanks again

Kind Regards

Jon

Hi Stewart.
Sorry i missed message, i have discovered the fault of my first problem, I was using a 4 core cable to from the socket to the HT unit, I have replaced this and outgoing now work.
Incoming gets passed from the HT unit to freepbx, but then gets dropped almost immediately, trying to solve that at the moment.
Thanks
Jon


(Ralph) #18

I can send you a word file if you post your email address which is very readable.
I do not think the forum has private messages.
I should add that my system is set up using pjsip so if you are using chansip the port numbers will be different.
Where I have blacked out my name for the HT you will need your name @your internal ip address for the pbx. I have all my phone system on fixed ip addresses so I know how to adjust settings easily.
As I said I do not use fxs for a phone but the settings are still required for ring frequency etc. I have never found a webpage for all the settings I gathered them in bits and pieces from several places.
All my phones are voipfones so the BT line rings in to the HT which transfers to the pbx and after options by the caller calls the relevant extension.
Outgoing my dialplan sends local calls and 999, 1471 to the BT line and all other to my SIP provider. So mobile numbers and international go out via SIP lines on the net.
Thanks for Christmas wishes and have a good one yourself.
Ralph


#19

Please paste the Asterisk log of a failing call, including SIP trace, as described earlier in this thread.