Configuration issues with SIP Trunk (please help)

I’m having very hard time to configure SIP Trunk on FreePBX. Here is SIP Trunk settings from ISP:

ID Range: 971436509xx
Pilot number: 97143650900

Username: 97143650900p
Pass: xxxxx

Host: fixedimsmey.duentdxb.duvoip.fmc
PORT: 5060

Please community help with this. Your time greatly appreciated.

  1. Access FreePBX: Log in to your FreePBX administration interface.
  2. Navigate to SIP Trunk Configuration: Go to the “Connectivity” menu and select “Trunks.”
  3. Add SIP Trunk: Click on “Add Trunk” and choose “Add SIP (chan_sip) Trunk.”
  4. General Settings:
  • Trunk Name: Enter a name for your trunk, e.g., “ SIP Trunk.”
  • Outbound CallerID: Set your outbound caller ID if required.
  1. Outgoing Settings:
  • Trunk Name: Enter a name for your trunk.
  • PEER Details:

Replace xxxxx with your actual password.
6. Incoming Settings:

  • Leave this section blank unless you have specific requirements.
  1. Registration:
  • Leave this section blank unless you need registration.
  1. Advanced Settings:
  • Set “DTMF Mode” to “RFC2833” or “Auto.”
  • Set “NAT” to “No” or configure accordingly based on your network setup.
  • Leave other settings as default unless you have specific requirements.
  1. Save and Apply Configuration: Click “Submit Changes” and then “Apply Config” to save your settings.
  2. Check Status: After applying the configuration, check the status of your trunk under the “Reports” tab to ensure it’s registered and functioning properly.
  3. Test: Make test calls to ensure that incoming and outgoing calls are working as expected.

Remember to adjust any settings based on your specific requirements or network configuration.

This is based on an obsolete channel driver, and should not be used for new installations.

It will cause Asterisk to challenge the provider for authentication, which they will almost certainly be unable to do (use remotesecret rather than secret), and includes an option that does nothing (username), in this context.

The username option should either go in fromuser, or be specified as authuser, depending on details that are not clear. It is not clear whether any caller ID is required, but if it is, how that is signalled, will depend on how fromuser is used.

1 Like

As @david55 said, but also note two other issues with the chan_sip implementation:

Item 7 says “Leave this section blank unless you need registration.” but item 10 says “… to ensure it’s registered and functioning properly.”

The offered config shows “host=fixedimsmey.duentdxb.duvoip.fmc”, which conflicts with the problem noted at Request-Line Invite change , which suggests that an outbound proxy is needed.

Thank you @danishhafeez, @david55, @Stewart1 for suggestions for configuration. Actually yesterday I did some research and found working solution. Currently testing stability for couple days. If it is successful I’ll share working settings for anybody to reference for this specific ISP.

Appreciate you guys.

1 Like

@Bohodir, did you find the solution for the PJSIP trunk? I tried many solutions but failed, except The Chan_Sip trunk without an outgoing proxy solution. Is there any way to override the pilot number? I have 100 numbers but outgoing calls always use the pilot number.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.