Cloud based FreePBX not connecting to phones

I’m almost certain I’m just missing one thing here or there, but at this point I’m completely stumped:

New Cloud based FreePBX installation, direct through a Sangoma hosted service. Server is up and running. I have a Sangoma S300 phone, which at this point isn’t even behind any firewalls anymore, on a static IP accessible via internet (as part of troubleshooting). I have the IP address of my Cloud server plugged into the phone:

Primary SIP Server is set to the IP of the FREEPBX server.
SIP Transport: I’ve tried all three.
NAT Traversal: Tried all three.
SIP user ID: I’ve tried both the extension# and the authentication ID
Authenticate ID: Currently set to the same value as is found in the server’s SYSTEM ADMIN>>Provisioning Protocols. Also, FTP and HTTP(S) authentication are enabled for both, using the same username and password for both.

Essentially, I’ve tried both under Account and Management in the phone’s settings, but it simply won’t connect to my FreePBX instance. Furthermore, I’ve opened up the FreePBX firewall to allow traffic to/from the phone’s IP. Between the Firewall on the FreePBX and the fact that the phone on my end isn’t even behind a firewall anymore (I have it sitting right next to the phone, but for purposes of troubleshooting I’m completely bypassing this for now), I’m stumped. Anyone have documentation on the cloud based FreePBX, or have any idea what I might be missing?!

You need to be setting up your phone in Endpoint Manager - it’s free for Sangoma Phones (so no cost there) and if you have the settings on the Server set correctly, the phone should come right up.

Be very careful opening up Phones and Servers to the Internet for the purposes of troubleshooting - there are TONS of people out there just waiting to exploit a vulnerable PBX or Phone - and no guarantee they will use it right away - they may just lie in wait and blast you over a weekend or evening.

My suggestion would be to contact the people you are renting the instance from and have them check your work and help you - customer service is there for a reason.

Thank you, but I’ve been in Endpoint manager the whole time. I’ve created S300 profiles, etc. Trunks are linked and a user account is set up, including for the phone. The customer help is only available at $400 for 2hours (prepaid). Right now I’m trying to do a proof of concept before I have our company jump on this (nonprofit). I’ve set up an internal server before and attached two phones to it - everything worked fine. Our goal was to have a server live “out there” in the cloud so that we can ultimately connect multiple locations to this one system, especially since this has the potential to cover all our locations by the time it’s done. I’ve hit a snag and one I can’t find any documentation on (cloud docs are nonexistent). In general, the documentation is rather lackluster and real downer on this product. I’m just hoping that someone ran into a similar issue or maybe has some idea.

BTW: I changed the pw’s for the administrative account on the phone. Everything else is buttoned down, i.e. I’m using the “adaptive” firewall built into FreePBX and only opened up access to the IP of the phone. Again, I’m just “testing” at this point.

Thank you for your input.

Telecommunications is not a trivial enterprise no matter what you read - there is a TON of complexity involved in getting an instance both working and secured.

I understand you are trying to do it on the cheap (we help out several Non-Profits) but the only proof of concept you may be demonstrating is that you are not able to configure all the proper things to make it work - no shame in that - I screwed around with Asterisk/FreePBX for 4 months before I had a working system - and that was when it was WAY more simple than it is now.

Don’t let this project fail because you can’t figure out all the various settings to get a working instance going - FreePBX is a God-Send for non-profits as the price is excellent (free for most aspects) and the power is incredible.

Beg/Borrow/Plead with the people you are getting the hosting with to help you - for someone that knows what they are doing, it should only be about 10 minutes to get the proper settings input and tested.

Good afternoon Harro,

Not an expert by any means but I have cloud hosted FreePBX and a Sangoma S500 lying about so I decided to give it a whirl.

I set up a new extension, the only thing I changed from the default was on the Advanced tab I selected “Yes (force_rport, comdia)” for the NAT Mode.

Check your global settings under Endpoint Manager.
You’ll need to know the port for HTTP provisioning along with the user name and password for provisioning.
Make sure the internal and external addresses are correct. In my case I have them the same since it’s in the cloud.

Then under Endpoint Manager ->Brands I went to Sangoma, and on to editing the default profile.
I made sure the “SIP Destination Address” is set to External
I set the “Provisioning Protocol” to HTTP
I set the “Provisioning Address” to External
Then in Sangoma_default->Models I set the keys that I wanted mapped on the S500 model and saved those configs.

Then on to Endpoint Manager->Extension Mapping. Add the phone with extension, Brand, model, account and mac address. Save and apply all that.

Then I went to, signed in.
Under Products->Sangoma Phones->List I found the phone in question and set it up to enable redirection, the redirection type I used was IP/FQDN (deployment ID did NOT work for me), protocol HTTP:// and then the address: provisionID:[email protected]:83 (83 should be whatever your HTTP provisioning port is listed in your global settings. Save that information.

Reboot the phone. It should check with Sangoma for it’s instructions and then on to your cloud server if all the firewall stuff is working.

Sangoma’s instructions for all this is here:

Hope you didn’t get hammered too badly by the recent storms!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.