[Closed ] Text to speech engine not available / due to lack of sound card?

Hi all,
I rechecking my whole config and seems that I missed some point almost at each step …
I want to use Text to speech ( TTS ) for IVR.
I updated module with the latest available and installed 2 TTS engine ( flite and google speech : ref here : TTS Engine Custom - Google Cloud Text To Speech - WaveNet and Standard )
When I go under application, text to speech, when I try to add a new text to speech item, in the configuraiton page, instead of having a list with the different TTS engines, I have " No AGI script found".
I tried to uninstall / reinstall TTS module, check permissions …etc…
Then I tried to run manually for ex flite. To do so I create a text file containing “hello world”.
When I run the following command I get


ALSA lib confmisc.c:767:(parse_card) cannot find card ‘0’
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1246:(snd_func_refer) error evaluating name
ALSA lib conf.c:4528:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:5007:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM default
audio_open_alsa: failed to open audio device default. No such file or directory
I understand that flite is looking for a audiocard. does this prevents freepbx in somehow or do I have 2 different problems ? ( config AND audio card issue )

Text to speech doesn’t need an audio card to work. Maybe you’re trying to send the TTS output to alsa instead of a file and that is why you are getting that error.

1 Like

Thanks arielgrin. So , I will close this thread and create a new one withthe issue of “no AGI script” available
Thx !

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.