Cisco CP-7912G-A configuration as a plain extension

You said . . .That’s neither a CLI or bash command. . . . , I clarified that it was an Asterisk thingy and the reason why it might not be working, so (patiently) back to the issue, from the asterisk command line where x.x.x.x is replaced by the literal ip of your extension 501 :-

sip set debug ip x.x.x.x

Plug the phone into the network, anything?

CLI> sip set debug ip x.x.x.x
Not a command.
CLI> set sip debug ip x.x.x.x
Not a ommand

Host]# sip set debug ip x.x.x.x
Sip not found
Host]# set sip debug ip x.x.x.x
No complaints, but did nothing.
Followed by the Hosr]# tail command, nothing displayed plugging in the phone ethernet.

Dear heavens above, please do all that stuff from the asterisk CLI that is when your prompt looks like

yourfreepbx*CLI>

that is your asterisk CLI

NOT, I repeat NOT

when it looks like

[email protected]:~#

that is your bash prompt.

to get to the asterisk prompt from bash, type

rasterisk

or

asterisk -r

There is a Wiki link at the top of this page, it is very comprehensive, you should spend a few hours there before you repost.

Perhaps you missed this:
CLI> sip set debug ip x.x.x.x
Not a command.
CLI> set sip debug ip x.x.x.x
Not a command

OK from the absolute basics (you need to learn the basics) . . . .

From the Asterisk CLI

type

sip

then press the tab key on your keyboard . . .

what do you see?

Ok, this was my fault, “Sip set debug 192.168.1.52” is NOT the same as “sip set debug ip 192.168.1.52”

Entering it properly,
Unplug and plug in the Cisco. Nothing.
Dial 112 from 501 (busy signal) Nothing.
Dial 501 from 112 (busy signal) Lots of messages.

In essence:
WARNING (function call) Requires a PJSIP channel.
ERROR (function call) Requires a SIP channel.
And finally
Unable to create channel of type ‘SIP’ (cause 20 - subscriber absent)

In the future, would it be too much to ask, when you find something wrong, other than just telling me its not working have extension 501 actually try to register against the ip of your Asterisk server, when you do that there WILL be a sip debug

If you want to continue to be pissy, then wait for someone else to help you

Perhaps if you’d be a little more forthcoming with help instead of your usual “RTFM” or “half answers” I’d be a little less pissy.

For example:

How do I do that?

wait for someone else to help you :wink: I don’t do pissy

You don’t do help very well either.

Some might disagree , look at my profile . . .

1 Like

All it says is essentially you spend all your free time here.

While trying to find solutions without having to deal with you, I’ve read numerous posts where your answers are predictable.
“RTFM”
“Read the Wiki.” Notably you pointing to Wiki about the Door Phones which returned a bank page. Yeah, that was really useful.
“That’s wrong” Without saying what it should be.
“That is a piece of crap.” Yeah, that’s equally useful.
“Pay someone to do it for you.”

I’ll have to assume you probably know how to make things work, but the image you display is one of someone that assumes anyone asking for help is “Too stupid to pour piss out of a boot with the instructions on the heel” because you know how to do it and they don’t.

Then you either berate them or give incomplete answers.

To tell you the truth, nothing would make me happier than not having to deal with you.
So, be my guest, don’t help me.

HeHe, so you are still pissy, I can tell you it won’t work here, please don’t worry, you will never have to deal with me again. Some might say that is your loss.

Thank you.

(Post Deleted)

Hi Jeffrey,

You complain about the behavior of others on this forum, but IMHO your own has been pretty poor. In your thread at Digium TDM2400P willl not dial out or receive calls , several members tried in good faith to help but were unsuccessful. Perhaps we didn’t ask the right questions or had insufficient knowledge. Eventually, you solved the problem yourself, but didn’t even have the courtesy to post the solution, which would be useful to someone else facing the same or a similar problem. Better, you should post:

  1. What turned out to be wrong.
  2. How you discovered what was wrong.
  3. Why you fixed it the way you did.
  4. If relevant, why it was hard (erroneous documentation, misleading error message, bad link, etc.)

This helps the makers of this fine hardware and software provide better documentation. It also helps those who answer to ask better questions and make better diagnoses. And, the thousands of lurkers who read this forum without asking or answering questions will learn something useful.

Next, when you post a log or other data, check that your post is easily readable; if not please edit it. If it gives me a headache to view, fat chance getting an answer. And if it’s longer than 100 lines or so, use http://pastebin.freepbx.org/ or a similar tool to reduce the clutter.

In defense of dicko, who is an awesome resource on this forum: Cisco phones are solidly built, very reliable, have excellent voice quality and a great feature set. Most fortune 500 companies use them, for good reason. President Trump said “These are the most beautiful phones I’ve ever used in my life.” https://www.nytimes.com/2017/01/25/us/politics/president-trump-white-house.html . However, >95% are used with Cisco proprietary Call Manager systems and most of the rest are deployed by IT experts in large organizations. Unless your goal is to learn about these complex monsters, they are not for amateurs! OTOH, a cheap Chinese phone (Grandstream, Yealink, HTek, etc.) can be easily configured with FreePBX in just a few minutes; most readers of this forum can do this without consulting any documentation.

Back on topic:

In the phone, try setting SIP Proxy to
192.168.1.123:5160
(replace 192.168.1.123 with LAN IP address of your PBX)
and use a short secret.

If no luck, I suggest that you shut down the phone and configure a softphone such as PhoneLite as extension 501. If you have trouble, report details. Once you get that working, you’ll know what configuration is needed for the Cisco and your ‘only’ problem will be learning how to get those values into your phone.

3 Likes

From my initial post:

I’ve done two things:

  1. I switch from Chan_SIP to pjsip and made it extension 502.
    And changed the secret from that assigned by Asterisk to “5101” A short secret.
  2. regarding the SIP Proxy, 192.168.1.34:5060 didn’t work, there is no : on the keypad.
    However, changing SIP Proxy from 0 to 192.168.1.34 worked.

I can call ext 112 from 502, and call 502 from 112.
I also called my cell phone via the telco line connected to an FXO port.

I’m glad to hear that you got it working. I agree that pjsip is the right way to go, unless it gives you intractable trouble. However, if you ever add external extensions or trunks to your system, you will probably want to change its bind port from 5060 to something non-standard. (Although this only improves security a little, it gets rid of nearly all the log entries from hackers beating on your system, making it easier to find stuff in the log that’s actually important.)

So, I’m curious why you had trouble entering :5160 or :5060 into the phone. I don’t have such a phone, but believe that to enter a colon, you just press the Alpha softkey then press the 1 key repeatedly until a : appears. (This is no different from entering alphanumeric passwords, etc.)

To be honest, it just didn’t occur to me.
In the number mode, you just enter numbers and use the * for the periods.
I went back and pushed the Alpha soft key and entered the : then Number again for the rest.
Interestingly, it works either way. 192.168.1.34 or 192.168.1.34:5060

One more question, if I add a second sip phone, do I use the same 5060 port, or do I need to use a different one?

The Local SIP Port setting on the phone doesn’t matter – you can leave it at 5060. There is no problem with two or more being the same, because the phones have different LAN IP addresses. If you were using a remote (cloud) PBX, it still wouldn’t matter, because your router would assign unique port numbers as part of the NAT process.

The remote port number (what you put after the colon, defaults to 5060 if a port number is not supplied) must match the bind port used by pjsip. This is 5060 now, but you should probably change it if you will be adding SIP trunks or remote extensions. The setting is found at Settings -> Asterisk SIP Settings, Chan PJSIP Settings tab, Port to Listen On. When you do change it, you will need to update each of your IP phones and other SIP devices and apps to match. For trunks using registration, it doesn’t matter because the provider will send your incoming calls to whatever port your REGISTER request comes from. For trunks using IP authentication, you put the port number in the appropriate place on the provider’s portal, usually by putting a colon and the port number after your public IP address in the field called SIP URI or similar.