Cisco CP-7912G-A configuration as a plain extension

Current Asterisk Version: 13.12.1

I bought this phone on the recommendation from a friend who has a 7912 phone working on an older version of Asterisk (command line, not FreePBX GUI)

Cisco 7912 firmware: CP7912080000SIP060111A

From the phone SIP menu:
SIP Configuration

  1. SIP Proxy 0
  2. User ID 123
  3. Password *****
    4/ Use Login ID: No
  4. Login ID: 0
  5. Local SIP Port 5060
  6. Local RIP Port 16384
  7. Backup Proxy Timeout 0
  8. Outbound Proxy 0
  9. Register Expires 3600
  10. Register New Proxy: No
  11. NAT WAN IP Address

And from the GUI
This device uses CHAN_SIP technology listening on Port 5160 (UDP - this is a NON STANDARD port)
Display Name
Garage SIP
Outbound CID

Language Code

User Manager Settings
Linked to User 501
Select User Directory:
Link to a Different Default User:

Use Custom Username
Password For New User

I have dial tone, but if I call another extension or call it from another extension I get a busy signal.

What did I forget this time?

I’ve read www.voip-info
And various topics to no avail.

Do you see the extension registered?

Please provide call logs.

And the command for that?

It is listed in the Extensions menu

No command. Check under Reports > Asterisk Info > Peers.

Name/username 501
Host (Unspecified)
Dyn D
Forcerport No
Comedia No
Port 0

1 sip peers [Monitored: 0 online, 1 offline Unmonitored: 0 online, 0 offline]

For starters your password is too long and you are using the wrong port .

That lengthy password is generated by the GUI menu. Do I go back and edit it to something else?
Which port is the wrong one? 5060 in the phone SIP Setup Menu?
What should it be then?

In the future, would it be too much to ask, when you find something wrong, other than just telling me it’s wrong, you suggest how I fix it?

There is a search box at the top of this page, there you will find that cisco phones peg out at 31 characters, and many other useful posts on howto configure ciscos.

From your post

. . .This device uses CHAN_SIP technology listening on Port 5160 (UDP - this is a NON STANDARD port) . . .

Searching for “Cisco 7912” yields the following results.
None of them are particularly helpful.
Some are downright hostile/patronizing.
One was never answered.
A good number of them predate the FreePBX GUI.
None of them say: “To configure you Asterisk PBX do this, this and this.”

Voice distortion on Cisco 7912 IP Phone using Free PBX on centos oS Distro Discussion & Help
Cisco 7912G (SIP) change AudioMode
How to Configure Cisco 7912G IP Phone with FreePBX
Cisco 7912g FreePBX registration problem
Cisco CP-7912G-A configuration as a plain extension
Pls help Configure Cisco ip Phone 7912
External Extension Delay
7912 not downloading gk file
Implemented QOS - Huge Difference!.
Cisco 7975 register but no able to place (internal) calls
Cisco 7961 on patched Asterisk 11: cannot make BLF working
Voice mail and MWI help needed
Problem with Cisco phone setup
Cisco phones firmware 9.0.3
No Audio until Noise on Outbound Call?
How to share /tftpboot
Panasonic KX-TGP500B01 nightmare
FreePBX, Google Voice, cisco IP Phone
EndPoint Manager adds support for Cisco Enterprise,Obihai, Panasonic and Yealink devices
404 error when trying to call extension from another extension

Bluntly, that’s why you can but them for 15 bucks on ebay, getting them to work with sip has caused many a grown man to break down in tears, personally I committed all mine to the trash can a long time ago.

So, let me see if I have this right.
So rather than offer any useful suggestions or help, you’re just going to tell me that they’re crap.

Thank you.

I was attempting to be helpful,

A) Shorten your password
B) use the same port on the phone and the PBX.

If you ttry that then maybe it will work. (but yes, they are crap and were never designed to work with anything but cisco stuff)


I changed the password to 5150 on both the phone’s SIP menu and on the PBX extension set up.
I changed the port from 5060 to 5160 on both the Phone’s SIP menu and PBX extension set up.

This device uses CHAN_SIP technology listening on Port 5160 (UDP - this is a NON STANDARD port)
Display Name House SIP
Outbound CID 2542101939
Secret 5150


Port 5160

Still get a busy signal, 301 dialing 112 or 112 dialing 501.

Chan_Sip Peers
Name/username 501
Host (Unspecified)
Dyn D
Forcerport No
Comedia No
Port 0
Status Unknown

Logs, Logs, Logs always logs, no one can guess.

Not sure if you did, but you HAVE to restart Asterisk after changing the bind port on the PBX.

As dicko said, you’ll need to provide logs, otherwise it’s just a guessing game.

[ Edited for brevity ]

[2018-03-08 15:15:59] WARNING[11379][C-00000002] app_dial.c: Unable to create channel of type ‘SIP’ (cause 20 -

Subscriber absent)

You can’t make a phone call until your phone (501) is registered

sip set debug ip the.ip.of.501

then paste show a log of when you plug in the phone to the network

And how do I do that?

That’s neither a CLI or bash command.

Well, it IS an asterisk cli command but only if chan_sip is loaded
I assume you replaced the.ip.of.501 with the literal ip of your extension 501

asterisk has “tab completion” so type sip “tab key” if no response then from the asterisk cli paste the issue of:-

module unload chan_sip

to unload it it

module load chan_sip

to load it

or just

module reload chan_sip

if it bitches, then you will need to unbitch it

And I asked you where to do that.

module unload worked.
module load has several WARNINGs about disply_nat_warning
module reload chan_sip made everyone happy, no complaints.