Cisco cp-7821

Hello All,

I am new to FREEPBX and I am enjoying the service thus far. I am currently in the process of developing a VoIP system at my house for I am a computer engineering student and wanted to have a fun project to work on during the summer. I currently have 4 phones registered to my system. I have 3 CISCO 7942Gs and 1 CISCO 7941G. Those phones function very well. I really like the look of the 7821s and would rather use those in place of the 7941s. I am having some trouble registering the phone. My TFTP server is pulling the correct files and updated the firmware on the phone. Then I had an error come up in the status section error verifying config. I had changed the port number and that error is gone. Now I am getting an error stating error updating user locale and error updating network locale. I am getting the correct date and time on the phone. The phone will not register, just states registration in progress. Attached is my config file. Any help would be greatly appreciated. I have starred out any password or username for my privacy.


There’s your problem - it’s not a valid XML File (use the right preformatted text option and try again).

Unless you’ve installed something to take the place of CallManager (like Chan-SCCP-B), you’re going to run into these kinds of problems (maybe even after). The files your phone is looking for (see /var/log/messages) need to be available and are only available for actual CM users.

The 7941s run better using the Skinny load - they are just not powerful enough to work correctly with the SIP load. There are a bunch of things that are simply not going to do what you want (most of the buttons, for example). If you want to pursue this further, at some point you are going to end up either installing Chan-SCCP-B (from GitHub) or patching your Asterisk to work with the phones (which means your ability to switch Asterisk versions is gone).

I have a link to the SIPxxx.cnf.xml file. Sorry the forum formatted the text terribly. Also where can I find Chan-SCCP-B and how do I go about adding it in to work with FREEPBX. Thank you

Use the “preformatted text” filter next time.

That has a lot of information, including a little bit of troubleshooting.

I have the following errors when trying to install the module to freepbx. Any help would be appreciated

It seems you have not created the required tables on the database prior to installation.

I followed the guide that was posted to a T, may you be able to assist in anyway so I can get this installed? If it helps, I am using asterisk 16 with freePBX 15

Can you post the exact link of the guide that you followed?

Only things that I did not setup was the TFTP and DHCP server for I have separate servers for each. Do these need installed?

I wrote the original version of this page, so I understand what’s supposed to happen. In the past, there was a step where you installed the database files. This should be happening early, but if it was skipped, the MySQL install script is available in the original installation files.

You’re not the first person I’ve talked to that’s had this problem, but it’s unusual. There must be a step somewhere that we’re missing. I don’t recall exactly where the SQL install script is, but it’s in one of the directories right on the installation source directory.

mysql -p asterisk < /usr/src/chan-sccp/conf/mysql-v5_enum.sql

When I type this command in, I type in my password and get an access denied error

Try mysql -u root asterisk < …

Try mysql -u root asterisk < …

Root worked, but I am getting the same errors as before. Is there anything else that I am missing or not doing and getting frustrated.


I have also tried both asterisk 13 and 16
This latest try is on 13
Any help is much appreciated

The FreePBX Instructions that I wrote are just for the FreePBX part of the installation. Have you followed the larger installation instructions that come with the module? Those steps are required as well.

What I have done is install from the git repository to asterisk, then the next step is to install the module in freepbx correct. That’s what I took from the instructions. CHAN-SCCP is installed in my asterisk and I have a chan-sccp directory in asterisk. That’s why this doesn’t make sense to me

There is an INSTALL step after you copy the files from the GIT repository. It’s pretty straight forward, but it’s not optional. These tables are required for Chan-SCCP-B to work.

In the Asterisk installation instructions for the module there’s a step where you install the database tables. That step installs the table you are missing. You can install it either as ‘root’ or as ‘asteriskuser’. I usually do it as ‘root’ because I install from the server and there’s no password (security is managed through the IP address ACL).

Try logging in to MySQL and type “select asterisk” then “show tables”. The sccp* tables should all be there and populated with data. If they aren’t there, something in the table install failed and you need to troubleshoot that.

Even with root, it still asks for a password and still says incorrect. Here is a screen shot of what I am doing. Also tried rootasterisk, asterisk.

I have installed the chan-sccp from github no probelm and have the chan-sccp directory. And even in that directory I get my password incorrect.

I hope the pictures can help you to help me trouble shoot as I am still a bit confused.

Thank you all for the help. It is much appreciated!

mysql -p tells mysql to ask for and use a password. Even if that password is blank, it’s going to ask for a password.

Unless something has changed (@mattf) the root user on localhost should not need a password. If that’s true, then telling mysql to ask for a password will give you an error (since providing a password when you don’t want one is …)