Cisco 7941G behind NAT, connecting to cloud FreePBX


I’ve got my 7940 connecting to FreePBX fine, but always knew that the NAT settings had to be reversed (whether right or not) on the 7941G to whatever the 7940 on the same network needed.

I’ve spent 2 days trying all combinations of my 7941G connecting to FreePBX in the cloud - the Cisco 7941G is behind a NAT / Firewall, and I’ve enabled:


And disabled that - all to no avail.

I’ve even tried to configure the outbound proxy, which is needed on the 7940 now to successfuly authenticate with FreePBX which is now hoested in the cloud.

The 7941G was working perfectly when sat behind NAT on the same network as FreePBX! :frowning:

Any pointers would be greatly appreciated :slight_smile:

That’s mainly due to the fact there was actually no NAT between the PBX and the device. Are all the devices on the same network? Do you have your firewall/NAT rules correct? Also, what type of router/firewall is this?

The 79XX series has a long history of sucking behind NAT so it’s going to take some fine tuning to make it happen. The network’s NAT capabilities will also play a big part in it.

The Freepbx is hosted in the cloud with its own open IP. The 7941G is behind a PFsense firewall with NAT and a 172. address.

Ive got the 7940 to connect like this, 7941G doesn’t have any of it. I even tried connecting on chan_sip but it didn’t even try connecting to my PBX on port 5160!


pfSense is notorious for handling SIP badly. Make sure all the “SIP Helpers” are turned off and that port randomization is off. Like I said 79XX’s are known to suck being NAT and the fact that pfSense is the router is compounding the 79XX’s poor NAT handling with pfSense’s poor SIP/NAT handling is not helping.

Check your pfSense configs and make sure those things are off.