Cisco 7940's & FreePBX

Hello im a new member here, im in need of some help hopefully not too much.
I have successfully installed and learned my way around FreePBX Distro. I have managed to create exstensions, SIP trunk. and all say online on the status page. i have my phones statically assigned to my network. The server says my phones are online. But next to my little phone Icon on the cisco 7940’s there is a little “x” icon. From the limited information i could find and no support from Cisco i have learned that the “x” means the phones are not registered fully. also everytime i try to make a call the phones say calling(out INV). I bought these phones second hand on ebay loaded with the SIP firmware 8-12. i do not have a copy of the firmware myself. I am lost and do not know where the problem is. why i cannot get my phones to ring each other, the outside world, or even register fully. i do have the endpoint manager for freepbx the non-commercial version it is not doing me much good, plus i am kind of afraid ill wipe out the sip firmware on the phones. if anyone can lend me a hand i would much appreciate it. im just a new guy with this. i can build networks, websites, but voip, lol different story. thanks p.s. i also do not know if some of my settings in phones are incorrect. what should my proxy and http be? thanks.

any help what-so-ever would be amazing. im just waiting to buy support last resort.

Have a look here:

It might help.

that guy solved it by turning NAT on. i do not need or use NAT. and i went ahead and went along with it and it still didnt work.
im beating my head into a wall lol haha any more ideas would be greatly appreciated.

You have not told us what you did!

Are the phones booting and grabbing the config file? Are they trying to register?

The phones on the same LAN as the Asterisk server?

NAT must be set to yes in the extension for Cisco, has nothing to do with standard NAT but with Asterisk’s ability to process different SIP message types. You can read the Asterisk docs on NAT declaritive if you want the blood and guts info.

thanks for the help. i do not know if they are grabbing the config file. also i do not know how to check if they are trying to register. ways to check this?

yes the phones are on the same lan and are statically assigned.
is there proper exstension numbers for cisco or asterisk? ex: 100, or 1000.

so NAT must be yes in freepbx and on the phones? ok thanks. i forgot the command in Asterisk CLI to get phone info. but i remember it says that the “status” is UNREACHABLE.

can i config the phone soley on the phone or must i edit files and upload via tftp. like i said i do not have the files i just have phones loaded with POS-8-12. i do not want to loose my files. ahah thanks

when i boot the phone this is what i see.

hope this tells a boat load.

I don’t think you can configure anything on the phone directly. It all has to be done through config files.

The phone is not registered.

Have you setup the endpoint manager?

i have tried. i added the model and everything and mac address but i still get a red status dot, im guessing that indicates its offline.

is may a firewall be the issue?

About 10 posts ago I asked you if the phones are on the same LAN as the server.

If they are not then you whole design changes.

They are. i was just curious. well im stumped. any suggestions for me to try? endpoint manager is not connecting to the phones, and if they are i do not know how to tell. man im lost. at a los for words. i do appreciate all the help so far. i know a lot of people have problems with these cisco phones and trixbox,freepbx,asterisk.

All this conversation and nothing substutive.

Did you reset them to default? Did you manually program the tftp address into the phone or is DHCP handing out option 66?

If you setup the endpoing manager did you correctly input the version of your software?

Did you copy the Cisco software to tftp boot?

Did you look at the log to see if the phones are trying to register?

Did you enable tftp logging and see that the phones are requesting the files?

The 7940’s and 60’s are the easiest of all of the Cisco’s to program as they use a simple ASCII format, no XML.

no i have not. if i reset the phones to default will i lose the SIP firmware? as i said before i do not have the firmware or cisco files. i did manually address the TFTP. but i do not have any files in the TFTP. in endpoint manager i put in the phone and model yes. do i need to use the Install firmware function in endpoint manager?

No I did not copy the software to the TFTP Boot, i do not have the software. the seller was not able to give it to me.

which log will show me if the phones are trying to register and i will check it.

again i do not have the files to put in the tftp to check for logging.

i am greatly appreciating the help. right now i have the TFTP address to the freepbx server. i do not have a tftp setup on it. i do have another tftp i could use though, but again no cisco software files. is there a way to download them from the phone so that i have a copy of them. or do the config files need to be built by hand?

tftp log, you will need to modify /etc/xinetd.d/tftp and add a -v to the server args option then restart xinetd, then you would look at /var/log/messages and see if anything gets pulled from the server.

whats the purpose of this? and must i do this from command line at the server or thru the GUI?

I don’t really know how to help you. You don’t seem to have a grasp on the most basic of concepts.

You ask how to tell if a phone is registered, have you looked at the Asterisk documentation? At least just go into asterisk (it’s asterisk from the command line) and type a few commands like ‘sip show peers’ and see what they do. It has built in help, just use the question mark.

As far as tftp, again read the man page for tftp. I doubt you even have it installed and configured.

For troubleshooting you should turn up the log level of tftp, it’s start file is in /etc/xinetd.d/tftp (add a -v to the start line). You must restart xinetd services (service xinetd restart) for the change to take effect. Then all transactions will be logged in /var/log/messages. Use the tail command with the -f option to watch live while you reboot phone.

Oh, check if tftp is installed ‘yum list | grep tftp’

I just gave you a ton of hints, I hope you can get on track now.

Oh, the Cisco phones have been discontinued so long that the software is all over the Internet. I don’t think it’s piracy if the phone is past end of support/life. Just Google. Hine, filename starts with POS or P03

ok thanks yes. i have been familiarizing myself with this system for a few weeks now on/off. i have great knowledge on networking. but this is different i do apologize for coming in here and asking for help before trully reading farther into it. i just did not believe it would be much harder than this. yeah the TFTP is not installed.

im getting this in CLI

Name/username Host Dyn Forcerport ACL Port Status Description
300 N A 5062 OK (98 ms)
400 (Unspecified) D A 0 UNKNOWN
Nextiva/19558686 5060 Unmonitored
5 sip peers [Monitored: 1 online, 3 offline Unmonitored: 1 online, 0 offline]

Ok, you have one peer online.

Did you install and configure the tftp?