CID Superfecta, is it possible to have more information when a call comes in?


When I receive a toll-free call I always end up with a “TOLL FREE CALL” as a name which is definitely not quite useful.

The situation is also similar for many other non toll-free numbers, I frequently end up with the name of the town and its province/state.

Lookups are not activated at my provider but I believe they should be relaying what they received, no?

I would like to see what the trunk provides but there seems to be no way to ask CID Superfecta to do this.

Did I miss something?

Thank you and have a nice day!


PS: Since I believe that makes a difference as far as caller id lookups are concerned I am Canadian…

We’ll see this with the provider information from cell phones.

If you change the Superfecta query order, you can change what gets reported. Make sure you have the Internal database listed first, then one of the many “Open CName” (not to be confused with Opencnam) sources. Then use the carrier provided information.

1 Like

The lookup source to use the CNAM provided by the trunk is called Trunk Provided.

Hi Dave!

Thank you! This is what I currently have but I will take a look at it again as soon as I get the chance…

Have a nice day!


Hi Lorne!


I know and it is listed before the one who gives me things such as “TOLL FREE CALL” and town + province/state…

I wish I knew what is actually provided by the trunk when I receive a call… I really like the test/debug screen but it doesn’t tell me what is provided by the trunk and/or why it is discarded (I saw the rules, I don’t know if what is sent by the trunk matches them or if it is simply empty)…

It would be nice if we could see the temporary results provided by those sources (before they possibly get discarded), is there a way to do this?

Thank you and have a nice day!


You can get the trunk provided info from the full log:

grep /superfecta.agi /var/log/asterisk/full

A typical call will include lines like this:

/var/log/asterisk/full:[2017-02-11 13:46:19] VERBOSE[25451][C-0000008e] res_agi.c: Launched AGI Script /var/www/html/admin/modules/superfecta/agi/superfecta.agi
/var/log/asterisk/full:[2017-02-11 13:46:19] VERBOSE[25451][C-0000008e] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: Executing Scheme..
/var/log/asterisk/full:[2017-02-11 13:46:19] VERBOSE[25451][C-0000008e] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: Scheme Asked is: ALL
/var/log/asterisk/full:[2017-02-11 13:46:19] VERBOSE[25451][C-0000008e] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: The DID is: 19xxxxxxx64
/var/log/asterisk/full:[2017-02-11 13:46:19] VERBOSE[25451][C-0000008e] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: The CNUM is: 90yyyyyy98
/var/log/asterisk/full:[2017-02-11 13:46:19] VERBOSE[25451][C-0000008e] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: The CNAME is: FARRELL A&M
/var/log/asterisk/full:[2017-02-11 13:46:19] VERBOSE[25451][C-0000008e] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: Starting scheme Default

The lines that log before 'Starting scheme…" are what is provided by the trunk before the lookups begin.

1 Like

Thank you Lorne! This is exactly what I was looking for…

I can’t check it for now but will do as soon as I get the chance…

While you are here, I have another small question about CID Superfecta…

I checked the code and I have a feeling this can’t be done without an API change but is it, or is it not, possible to provide the DID called when sending emails or notifications (like Pushbullet for example)?

A quick glance at the code suggested the information wasn’t sent to the CID Superfecta modules but maybe I am wrong…

Thank you and have a nice day!


Check out the Send_to_Growl source for how to get the DID.

Hi Lorne!

Sorrrry for the delayed reply…

I checked and I found the “getter”…

I tried it and, surprisingly, it was empty…

I tried hardcoding what it was returning and that did worked…

I will take a look at it again this weekend if I have time to figure out why it ends up being empty… I see where it’s populated but something on my PBX seems to keep from being properly initialized…

Thank you and have a nice day!