CID Caller ID on picked up call not transmitted

Hi all,

I use Freepbx 13 / Asterisk 13.15.0 with up to date modules and I’ve a problem with the Caller ID transmission during call pick up on extension and ring group call.

I have a Ring group 600 with 2 members : extensions 100 and 101

When a call arrives on RG600 and I pick the call with **100, the caller ID is not transmitted.
When a call arrives on extension 100 only (not the ring group) and i pick up the call with **100, the caller ID is transmitted correctly.

I don’t understand. I use Yealink phone T46G all configured with lookup source on PAI - RPID - FROM
The extensions are configured in Freepbx with Trust RPID = Yes and Send RPID = Send PAI

Any ideas?? I’m lost.

Thanks all.

I am seeing some issues as well. What do you see displayed for caller id when you do a directed pickup using


I just tried it with **600 The same result. The Caller ID is not transmitted.

Any other idea ?

Should I post this on Asterisk bug tracker ?