Changing "Request-URI" when using outbound proxy


I’m trying to set up PJSIP plugin, but I’m unable to get inbound calls.

I suspect it comes from the Request-Line. This is the one I send when registering with SIP legacy plugin (that works for me) [marked as 1 in the image below]

Whatever, when I try to register with PJSIP plugin, the Request-Line changes for the set proxy [marked as 2 in the image below].

The IP where I have to connect is, indeed, But when setting up the proxy in PJSIP, it seems it is automatically set as Request-URI.

The configuration it is working for me in SIP is:

Registry String: +349************************

And the configuration I’m setting in PJSIP is [3 and 4 in the image below]

All other settings are as set as default.

Do you have any idea about what is going on here?

Thank you.

chan_pjsip proxy URLs are treated as though they had been in a Route header, which mean that, for the equivalent of chan_sip simple outbound proxies, you need to append ;lr (and the ; must be escaped with \ ) to indicate loose routing. It is normally advisable to also append ;hide (again quoting the ; ), which, I think, prevents an actual Route header being added, and may be a PJSIP special, as I don’t know of an RFC that covers it.

This was covered recently, although I can’t get the search engines to find it.

That worked!

Just in case someone is the same situation as me, the outbound proxy is now “sip:\;lr” for my settings and left blank “Client URI” and “Server URI”.

Now the inbound calls doesn’t seem to be establishing, allthough the phone rings. But that’s another issue that I will be solving, hopefully don’t needing the help of the forum.

Thank you!

I think the forum ate the back slash!

True. Now it shows :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.