FreePBX | Register | Issues | Wiki | Portal | Support

Changing recordings location to ReadyNAS and limiting incoming calls to one per time


(BlackMagic) #1

Hi, I’m pretty new in all the PBX stuff since I’ve changed my job recently :slightly_smiling_face:

The thing is, I am trying to reconfigure some things in the PBX. First of all I’ve enabled call recording in one extention to check if it will work - it does. So the thing is that I want to store the recordings on the ReadyNAS server - is it possible? Should I somehow try to mount ReadyNAS smb on the PBX server and then try to setup the path in the web console?

Second thing is - how to limit incoming calls in the extension settings? Right now, when there are few incoming calls at one time, everyone has the normal dialing signal, just like the line is not used at the moment.
I want them to hear “busy” signal or sound message saying “all the lines are busy ATM” or something similiar. How can I do it? I’d love to get a step by step guide if possible.

Cheers!


(Itzik) #2

You can change the call recording location in advanced settings. There’s plenty posts on this subject, here’s one:

Regarding call limiting, depends how you route your calls.
If you use a queue you can set if there’s no available agents to jump to failover and play this busy recording.
If direct extension, you can turn off call waiting, or limit the channels for that extension.

If you tell me more about your call flow, i can try to point you in the right direction.


(BlackMagic) #3

As far as i know there is no queue set up. It’s just an extension linked to user, with Inbound CID. It’s our secretary’s phone, her internal number ends up with 100 and the “main company number” ends up with 300 and is redirected to her. I tried to change “Busy” in advanced options but it doesn’t do anything.


(Itzik) #4

I’m a bit confused.

You have the main DID which is pointed to where? to an extension? How do you redirect?

Busy will only work if the receptioninst is on a few calls, or you can just do as i said eariler, disable call waiting, then once there’s a active call the 2nd call will get the busy messgae.


(BlackMagic) #5

Okay, so Call waiting did the job.
I was also able to map the ReadyNAS in PBX server and I’ve changed the location of the recordings in the panel but it is empty even tho I’ve made a few test calls. So the recordings aren’t saved there. Which user is used by PBX server to save recordings? Do I need to give him special permisions?


(Itzik) #6

I never tested this, i’d start by a call log and see whats happening.


(Lorne Gaetz) #7

If the mount you are saving recordings to ever goes away, calls will stop working.


(BlackMagic) #8

Why is that? This external server is only the storage for saved calls. Even if it goes down how will it cause whole calling system go down on the other machine?


(BlackMagic) #9

Ok so I’ve chmod777 the recordings folder and it didn’t help. In the logs there is an error:
file.c: Unable to open file: path - No such file or directory
and then
app_mixmonitor.c: Cannot open: path

That’s all I can see.

@edit
So I’ve created a forest inside witch matches the forest in the error - there were date folders missing. Now I’m getting permission denied error.


(Itzik) #10

You gotta give permission for the asterisk user.


(BlackMagic) #11

I belive that I have to create user on ReadyNAS with name asterisk and same password as on the PBX server. I’ve chown’ed and chmod’ed the folder once more and I’m still getting permission denied error. I think it’s caused by the ReadyNAS server that doesn’t have asterisk user and doesn’t let him write down anything. What will be the password for asterisk account on PBX server? Is there a standard password or previous person that was managing it set it up and I don’t really have access to it now? In that case - can I change it somehow?

@edit
Ok so this is weird, beacuse as root on PBX I am able to create folders and save files on NAS from the command line on PBX Server, but recordings are not saved cuz of lack of permissions. I’m confused.


(BlackMagic) #12

Ok so I belive I have found a workaround. I gave up on permissions and just simple rsync did the job :slight_smile:

It is syncing every 15mins and ignores existing recordings, maybe it’s even better beacuse recordings are stored in 2 places :slight_smile: