Changing IP address on server kills trunk

Hi guys,

My issue could be firewall or/and routing related, and it´s driving me nuts. :slight_smile:
I have two freePBX:s (primary and backup) (see below for version) running on a 192.168.n.n lan behind a Cisco firewall. The Cisco has a NAT route: Our static public IP address is NAT:ted to the inside address of the FreePBX. Everything works fine this way, until I shut down the primary and change the IP of the Backup to the primary´s IP. Then I cannot get calls from our SIP provider. Our provider tells me that calls are rejected at our end. I have tried disabling the firewall in GUI and CLI (fwconsole firewall), opening up for our SIP provider´s IP address in the firewall, rebooted our Cisco firewall. Nothing seems to help.

Have anyone heard of a similar issue?

I´m using the official freepbx distro, version 10.13.66-17.

Thanks.

Make sure that in Settings -> Asterisk SIP Settings, External Address and Local Networks are set correctly. If you overrode these for Chan PJSIP or Chan SIP, check them as well. I’ve seen cases when Save Changes doesn’t update them correctly; restart Asterisk (or reboot the server).

If no luck, check whether anything appears in the Asterisk log on an attempted call. If not, see whether any incoming INVITEs appear in a tcpdump capture. If not, see whether anything is logged at the firewall.

If still no luck, please report: Do internal calls work ok? Outbound calls with this provider? If this is a ‘register’ trunk, does Asterisk show it properly registered? Provider show it registered from proper IP and port? Are you sure your Primary isn’t sending a competing registration?

If the trunk uses IP authentication, are the provider IP addresses properly configured in the trunk?

If you have trunks with other providers on this server, do they work ok?

“Rejected” sounds like there was more than just no response to their INVITE. Get some details. If there is an ICMP error (host or port unreachable, administratively filtered, etc.) this is probably a firewall issue. If it’s a SIP error (401, 403, 5xx), the Asterisk log should give some clues.

1 Like

Thank you for your reply. You led me in the right direction. I only needed to change the Settings > Asterisk SIP settings > Chan SIP : NAT = Yes. I can´t believe how I missed this. Thank you for your time.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.