Change password (CLI)

Hi !

I want to change meetme pin password (for conferences).

How to modify it with CLI ?

Thank’s

Up ? :slight_smile:

Up please

Nope - I googled it and I can’t find anything that will do it from the CLI.

It is stored in the asterisk sqlite3 database under the family

CONFERENCE/nnnn/

OK then, you should be able to change it from the Asterisk CLI with a command like:

database put /CONFERENCE/1111 userpin 1234

This command show “database update correctly” but nothing, userpin is the same.

Check the Asterisk database and see what the PIN in the ASTDB currently is. It’s possible that FreePBX is resetting the PIN when up reload the options (Apply Changes), so the update to the FreePBX database may need to be there to back up the ASTDB change.

@jfinstrom, @lgaetz, or one of the other programmer types from Sangoma might be able to provide a little insight into what would need to be done to make this work for you.

Thank’s for your response !

I check it with mysql or other ?

I’d hang loose here for a little while and see if one of the database experts gets back to you. Failing that, you might end up schlepping around in the database to see if the setting is managed in there as well.

UP ? Can you help me ? :slight_smile:

OK.

The PIN setting in the database is the one used by the conference, so either you aren’t updating the right key in the database, or something else is going on. For example, if you do something that causes an “Apply Changes”, the user PIN that’s stored in the GUI could be replacing the one in the ASTDB database.

I tried it on one of my conferences and it worked expressly the way we described, so there’s something different about what you are doing and what I’m doing.

Can you tell me what are you doing ?
How you make apply changes ?

From a running system, log into the console as “root”. Run “asterisk -vr”. At the CLI prompt, type the following:

database put /CONFERENCE/9301 userpin 1234
exit

The User PIN on the conference is now set to 1234.

Userpin always incorrect…
Maybe i need to apply changes ?

We speak about that, we are agree ?

I deleted all number for preserve (it’s for my company so…) but conference number is 400.

Asterisk’ behavior reflects the value in Astdb, the gui will reflect the values in the meet me table in the mysql asterisk database, such values would be only committed to the current asterisk behavior after the database is committed, either by clicking the red bar in the gui or sending a :fwconsole a r’

[[email protected] ~]# fwconsole a r

[InvalidArgumentException]
Command “a” is not defined.
Did you mean one of these?
start
certificates
firewall
userman
restart
reload
ma
moduleadmin
notification
externalip

Reload

Code invalide… again…
localhost*CLI> database put /CONFERENCE/400 userpin 200
Updated database successfully

[[email protected] ~]# fwconsole reload r
Reloading FreePBX
Téléchargement réussi

When you fwconsole reload, you overwrote the astdb value you just set with what is in the mysql meetme table.