Chan_dongle or something else

Hello,

Before the device burned down, on the Raspberry Pi, a service was running through a 3G modem(Huawei 3131), for recording incoming calls and had a service for sending SMS messages.

Now that I’m not able to get a RaspberryPi, FreePBX is installed on the PC.

I need to somehow activate a 3G USB flash drive.

Of course, I ran into a number of problems there. And I would like to ask you to help me solve the problem so that the system will initially work.


I have installed FreePBX 16.0.21.9 on my PC.

Current system version: 12.7.8-2208-2.sng7

USB modem: Huawei E3131 with SIM card.

When run the command ls -l /dev/ttiUSB* I get the following:
[[email protected] ~]# ls -l /dev/ttiUSB*
crv-rv---- 1 root dialout 188, 0 Nov 14 12:25 /dev/ttiUSB0
crv-rv---- 1 root dialout 188, 1 Nov 14 12:25 /dev/ttiUSB1
crv-rv---- 1 root dialout 188, 2 Nov 14 12:25 /dev/ttiUSB2

When enter the asterisk -r command:
freepbk*CLI> dongle show devices

Then I get the message:
“There is no such command ‘dongle discovery’ (type ‘core show help dongle discovery’ for other possible commands)”

I don’t have options for the dongle, nor to change and configure the dongle.

Where should I pay attention? Which part?

The chan_dongle module is not part of Asterisk or part of FreePBX. It is external, so if you haven’t done the work to get it installed then it won’t be present.

Do you have any reliable sources where I can download a chan_dongle for my version of Asterisk?

I have tried few sites, but installation wasn’t successfully.

It would be good if there were steps on how to install it and in which repository.

As it’s not a project I have any involvement in, I have nothing further on it.

1 Like

My impression is that chan_dongle isn’t being maintained, so you may find there is a ceiling on the version of Asterisk under which it will run.

I’d certainly expect that you would need to compile it from the source code.

The advice for those wanting mobile air interface access in a commercial environment is to use SIP to air interface gateway, connected over Ethernet. Raspberry Pi /chan_dongle, is, basically a hobbyist’s configuration.

I don’t understand why you are not able to obtain a replacement Pi.

I was also thinking that I should probably find an older version of Asterisk that would be compatible with the chan_dongle currently found on popular sources.

The delivery time Raspberry Pi, as well as the current price are not profitable for me for this small venture.

Then you will be completely on your own, support wise, when installing EOL/unsupported versions of Asterisk and FreePBX.

Conversely, do you have any suggestions as to what I should do. So I’ll try to google it.
Any suggestion, tips…