Cdr_adaptive_odbc.conf lossing change on pbx changes

bug
Tags: #<Tag:0x00007f24c4220fc0>

#1

Hi, i need to have custom cdr_adaptive i configure the cdr_adaptive_odbc.conf like this
#include cdr_externaldb.conf
module reload cdr_adaptive_odbc.so works fine, but if i made some change in the web i loss this line in the cdr_adaptive_odbc.conf


(TheJames) #2

All changes should only be made to _custom.conf files


(Lorne Gaetz) #3

There is no supported way to add edits to this file. Needs a feature request to add an include for

cdr_adaptive_odbc_custom.conf

https://issues.freepbx.org/


#4

Hi, thanks for your time and help, The million dollar question, why did they take it away?
becuase the cdr_adaptive_odbc_custom.conf don’t exist in the file system in the /etc/asterisk


#5

the cdr_adaptive_odbc_custom.conf don’t exist in the file system in the /etc/asterisk


(TheJames) #6

It wouldn’t have been removed, it is more likely nobody ever requested it as it is a 1 line thing


#8

:disappointed_relieved:


#9

but in all previous versions of FreePBX it had this file, and it could make several connections to external DBs, for example in FreePBX version 15.0.16.72 i have the file cdr_adaptive_odbc_custom.conf on this new version i don’t have :frowning:


#10

Asterisk /FreePBX will look for any ’#includes from cdr_odbc.conf which is generally a single line

#include cdr_adaptive_odbc.conf

Apparently unlike other FreePBX conf files this oner does not #include the ‘custom’ file

cdr_adaptive_odbc_custom.conf

You can probably safely add that to the root conf cdr_odbc.conf file which should have the same effect without being overwritten. But yes for niceness perhaps file a bug or suggest an ‘improvement’


#11

Hello thanks for your time and help, when I add it to the cdr_adaptive_odbc.conf file in this way #include cdr_external_db.conf and I make a module reload cdr_adaptive.so everything works fine, now if I make any modification through the web, I add or delete an extension the cdr_adaptive_odbc.conf file returns to its normal state and removes the line that you add, to mitigate this problem edit the cdr module and comment the following code

//Rewrite the file
	//\FreePBX::WriteConfig()->writeConfig('cdr_adapative_odbc.conf', $content, false);

commenting on this, I prevent #include cdr_external_db.conf from being removed within the cdr_adaptive_odbc.conf file and it can continue to collect my cdr data


#12

Yes it is’ a little convoluted, FreePBX maintains cdr_adaptive_odbc.conf but the original authority is as I pointed out, cdr_odbc.conf, which is probably only modified by FreePBX on a major update (if ever) Just be brave and do it there.


#13

ok, to day i will test this recommendation i will create the file cdr_odbc.conf an test


#14

You want ‘Belt and Braces’? make that file ‘immutable’


#15

:space_invader:


#16

qut na’ HInob


#17

to day i try to use the cdr_adaptive in remote mysql database and the cdr_adpative is no sending the information to the database, when i do a module reload cdr say is connected but is not working

Call Detail Record (CDR) settings
----------------------------------
 Logging:                    Enabled
 Mode:                       Simple
 Log unanswered calls:       No
 Log congestion:             No

* Registered Backends
  -------------------
 **Adaptive ODBC**

(system) closed #18

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.