Can't Register Zoiper Android

I’m trying to connect a Zoiper Android instance to FreePBX. After creating the extension and secret in FreePBX and then configuring Zoiper I see in the logs:

[2017-05-30 17:00:11] SECURITY[1534] res_security_log.c: SecurityEvent="ChallengeSent",EventTV="2017-05-30T17:00:11.045-0700",Severity="Informational",Service="SIP",EventVersion="1",AccountID="101",SessionID="0x70768cd0",LocalAddress="IPV4/UDP/",RemoteAddress="IPV4/UDP/",Challenge="2fecbbe4"

Which is the cell phone. But Zoiper continues to give

Registration Failed (Request Timeout (408))

I installed also the Windows software – that connected just fine on another extension.

Any ideas.

chan_sip or pj_sip?

Chan_sip just like the extension for the Windows client

means that your phone cannot reach the server, so are you using wifi in the same network segment? If using WAN did you allowed the ip addres in the permit section and in your firewall?

Unless you have your cell phone on WiFi being on the same network as your PBX, you need to allow sip traffic UDP port 5060 through your firewall, otherwise your registration attempts from Zoiper will be denied on your firewall.

Forwarding traffic udp port 5060 to your pbx from ANY IP address is dangerous, so it’s usually restricted to known IP addresses, which isn’t really practical with cell phones, cause their IP address changes all the time.
So you can use a dynamic DNS client and allow the hostname, or use the responsive firewall or use sip URIs.

Yes, this is on the same segment. The phone is reaching the PBX as evidenced by the log entry I shared. Somehow the registration is failing.

actually the security log only show the challenge sent event. You need to provide the sip debug of the original REGISTER sip message.
Register with response->
<-auth ok

I’m not seeing a different message in the log. Only the one I provided repeated many times.

Now the Zoiper Windows client registers just fine:


That’s the security log. We want to see the Asterisk log.

Also try to switch wifi off on the cell to see if that works.

Setting the log display to freepbx.log instead of “full” I don’t see anything about extensions being registered. I’ve also searched the logs from the command line. Still not seeing anything.

Sip set debug on

Do you see any sip packets coming in from the Zoiper client?

Yes, the registration is being attempted as the log entries attest. The user/extension number is correct for both the Windows and Android clients.

We need to see the sip debug not the security log. Run:


Then try to register with your Zoiper, when it timeouts CTRL+C in the asterisk cli and finally upload the sipdebug.txt

So I see from the cell phone:

<--- SIP read from UDP: --->
REGISTER sip:raspbx.pvt;transport=UDP SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK-524287-1---0f194f4c931e5f73;rport
Max-Forwards: 70
Contact: <sip:[email protected]:43918;rinstance=40ffcc96daf919c8;transport=UDP>
To: <sip:[email protected];transport=UDP>
From: <sip:[email protected];transport=UDP>;tag=8c600057
Call-ID: 6FCB4fRUTclzg2K5ZveT6Q..
Expires: 60
User-Agent: Zoiper rv2.8.30
Allow-Events: presence, kpml, talk
Content-Length: 0

And the response from FreePBX:

<--- Transmitting (no NAT) to --->
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP;branch=z9hG4bK-524287-1---0f194f4c931e5f73;received=;rport=43918
From: <sip:[email protected];transport=UDP>;tag=8c600057
To: <sip:[email protected];transport=UDP>;tag=as6d063a23
Call-ID: 6FCB4fRUTclzg2K5ZveT6Q..
Server: FPBX-
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="3365e4d0"
Content-Length: 0

So clearly an “unauthorized” response. But I have carefully setup and checked the secret in FreePBX and the password in Zoiper.

Your 401 Unauthorized response is the authentication challenge from your server, not necessarily an error.

We need more logs.
What’s coming after that?

I pulled what I thought relevant from the verbose logging you had me create. I don’t want to post the whole log. What events are you looking for?

After installing and trying two other soft phones I’m wondering if this isn’t an Android 7 issue.

Zoiper seems to be replying to private address space (10.x.x.x). Is this what you want in your setup? If zoiper is connecting from outside your network you may need to check off the rPort settings in zoiper for signalling and media.

Yes this is all on my LAN. No NAT or other confusion.