Can't reactivate module after NIC change

Okay, I did not realize that module activation is tied to my NIC MAC addresses. I run in a VM and had to change these; When I logged back into FreePBX, the modules I purchased were no longer activated.

The problem is, I get an authentication error when I try to do my activation. I am guessing I forgot my password, but when I request for the system to e-mail me a link to get my password reset, I am not receiving anything in e-mail. Even tried to have it e-mail my username first, and not getting those either.

Yes I have checked my spam folders.

Can anyone please assist?

EDIT: Was finally able to find the proper page and got my password reset. Can be closed.

Is this actually true?

That’s horrifyingly scary given how MAC addresses are so easily forged, not to mention certain OS’s who randomize them

How so scary? if you change the MAC, commercial modules fail, no? There are two levels of looking at MAC addresses, the hardware chip has one embedded, the NIC interface as you say can be modified, it gets more interesting in a Virtualized environment, both can be spoofed, zend gets emasculated . . .

My guess is that my last sentence spelled the demise of zend :wink:

It appears to be. Basically I run in a VMWare environment. I wanted to do a switch so my external and internal NICs swapped eth0/eth1 positions. After shutting down, swapping those 2, and booting back up I lost activation and had to re-activate.

try reassigning them back to where they where in udev. generally /etc/udev/70-persistent-net.rules

change eth1 to eth0, and eth0 to eth1 or whatever matches your old/new mapping

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.