Can't park outbound calls

I am running FreePBX and crated a park group. I can park calls that come in no problem with the *71 option. But when I try to park a call that originated from the system to the outside I can’t park it. Anyone have any ideas?

What message are you getting at the CLI when you try to do it - or over the phone?

When I run a astrisk -vvvvr I see the call connect and wait for about 15 seconds to make sure nothing new is happening. When I press *71 or in my case I reconfigured for *1 there is nothing logged.

Sorry… no message on the phone at all. The person called can hear the touch tones… but the system is not reacting to them.

Generally a problem with codecs used and dtmf method, for example dtmfmode=inband won’t work with g729 as a codec, only g711 can . Also g729 won’t work at all without valid licenses no matter what dtmfmode you choose , asterisk can only do “pass-through” in that case and a parked call will not/can not “pass-through”.

I was just double checking all of that. My provider requires 2833 and I thought I had the Polycom phones set to that. I will check that on the extensions. I also made sure my outbound dial options have a Tr.

Alright tried two ways. I tried making my dtmfmode=auto with the phone coded only to G.711. No-Joy Call worked but still could not park it.

Tried changing the dtmfmode=inband with the phone still on G.711. Again call worked dialing out, but could not park it.

I just tested by calling DirectTV and the touch tones work fine for navigating through their IVR. :frowning: I see from searching that others have had this problem and it was fixed by adding the T to the dial options. That has not fixed it for me.

Recent security concerns as to call transfer might have defeated your ability to do that any more in FreePBX

I wonder how I could find out if this is the problem?

You would have to ask the dev’s if your use case is now “patched”

I saw this and I have to ask the obvious stupid questions:

Are you trying retrieve a call from the parking lot (*71 recalls the first parking lot slot) or are you trying to park a call (which would normally be *70)?

Also, did you disable in-call recording (which is also *1)?

Dave, Great questions.

  1. *1 is disabled call recording is disabled. I pretty much disable all features we are not going to use which is most of them.

  2. Parking, I changed the system to the following:
    Park a call: * followed by the parking spot 1 " this works as long as the call is an inbound call"
    Pickup a call: 2 “this is the parking spot where the first call is parked. Again this works as long as it’s inbound calls”