Can't make calls from outside the local network

I need some help with my FreePBX server… it’s working as long as I am in the same network ( connected to my router )
but if I try to connect to it it if I am not at home it won’t work … It registers the user but the calls will time out because the packages won’t go trough … I tried Exposed host to check if it will work then but I got the same Issue … can someone help me ?

Some easy things to check:

  1. In Asterisk SIP settings, External Address is your correct public IP address and Local Networks is properly set. Restart Asterisk if you change these.
  2. In your router, UDP port range for RTP (default is 10000 to 20000) is forwarded to the PBX server. (That’s not the same as Exposed Host a.k.a. DMZ, which should be left off.)
  3. Any router settings related to SIP ALG or SPI are turned off.
  4. If using chan_sip, extension is set nat=yes.

If you still have trouble, post a SIP trace (at the Asterisk command prompt, if using pjsip, issue pjsip set logger on , if chan_sip do sip set debug on . Make failing test call, view Asterisk log to see the trace.

Also please post:

Modem make/model? Separate router, if any? Server platform? Virtualization, if any? OS version? FreePBX version? Asterisk version? IP phone or ATA make/model, softphone version, or SIP app version? If on mobile device, does it fail both on mobile data and over remote Wi-Fi? Any special settings in user device (other than server name, user ID and password)?

When calling *43 (echo test) from the remote device, do you hear the announcement? Does the echo test work? What happens when you call a local extension from the remote extension? The remote extension from a local extension?

I changed the IP settings in Asterisk SIP settings.
I tried to Forward all Ports from 10000 to 20000 ( UDP ) unfortunately I run in trouble doing this because after port 11791 it seems that I can’t forward the ports the external ports would be ~62200.
I added a nat=yes in the chan_sip extension.
The router is a Fritz!Box 7490.
Virtualization is Virtual Box ( Network Bridged ).
Asterisk version is 13.18.4.
I use the Android app “Zoiper” ( newest Update ).
No Special Settings. I wasn’t able to try it on another Wifi-Network.
If I call *43 I wont get any response the call drops after ~6 Seconds ( tried with Forwarded ports between 10000 - 11791 ).
I call start a call from my local extension to my remote extension but the voice would not be transfered ( the same Issue as when I called *43 ).

OK, so change Asterisk Sip Settings, RTP Port Ranges from 10000-20000 to 10000-11000. Restart Asterisk. In Fritz!Box, forward external UDP ports 10000-11000 to FreePBX. Retest. If you still have trouble, post a SIP trace.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.