Can't connect D80 to FreePBX - Configuration PIN?

First and foremost, my apologies if this is in the wrong category.

I’m having nothing but issues connecting my D80 phone to FreePBX using Digium Phones (either in Easy Mode or not Easy Mode). My phone does detect the server over mDNS, but connection returns an error:

 Server URL Not specified in mDNS response

Attempting to connect to the server directly (or via DHCP 66) does actually establish a connection to the FreePBX server, but prompts for a Configuration PIN that I do not know. The defined Global PIN does not work, neither do any phone PINs or anything else.

Additionally, the mDNS service name shown on the phone (Asterisk) does not match the configuration name shown in my control panel:

What is going on, and what can I do?

I have FreePBX running on Asterisk 13, and the Digium phone is version 1.9.5 currently. The module is at version The builtin FreePBX firewall is being used, and yum reports no updates available.

Edit: My Dashboard is also returning the following (related?) message:

retrieve_conf resolved a symlink with
This is a notice to let you know that the original file was moved to /etc/asterisk/backup, there is nothing more you need to do 

The file itself is not a symlink (?) but also just has a number of commented includes. The config files are owned by user/group asterisk:asterisk, and all have 664 with the exception of res_digium_phone.conf which keeps changing itself back to 644.

As an experiment, I tried changing the res_digium_phone_general.conf file’s service_name, which did take - suggesting that the UI isn’t syncing with Asterisk for some reason.

Found my own solution to the problem:

I needed to disable Endpoint Manager as it was interfering with the legacy Digium controller (which I can’t use as my phones are used and I don’t really want to pay $150 for my tesing PBX). Once that was done, the phone detected everything straightaway. The PBX’s proper mDNS records showed up, everything worked.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.