Can't change time to voicemail

Hello!

I have a FreePBX 12.0.74 installation set up as follows:

  • 2 SIP trunks which can receive and make calls
  • Incoming calls on both SIP trunks go to a ring group containing two extensions: 1000 and 1001 (both of which are SIP extensions)
  • 1000 has voicemail set up

When I receive incoming calls on trunks, both 1000 and 1001 ring for about 7-8 seconds then calls go straight to voicemail.
When I call 1000 from 1001, 1000 rings for 7-8 seconds then goes to voicemail.

I have tried:

  • Changing “Ring Time” under “Extension options” for extension 1001 to 30 seconds
  • Changing “Ringtime Default” under “Dialplan and Operational” in “Advanced Settings” to 30 seconds

None of these changes have had any effect whatsoever regarding time to voicemail: still, after 8 seconds incoming calls go to voicemail. (Yes, I have pressed “Apply Config” every time after changing these settings)

What am I doing wrong?

I’m confused. You’ve turned on voicemail, and yet you don’t want calls to go to voicemail? Maybe you should explain what you EXPECT to happen?

My bad. What I really want is to increase the time to voicemail to something like 15-20 seconds.

I tried all the above, but no matter what I try the phone only ever rings for 5-7 seconds.

The default is set in Admin -> Advanced Settings -> Ringtime Default (and is set to 15 seconds by default). To override this on a per extension basis it’s Extension Options -> Ring time.

If you’ve changed them and they’re not taking effect, can you please paste a call log of a call happening and going to voicemail too quickly. Can you also ensure you are up to date with all modules, and tell us the voicemail module version.

Hi.

Here you are the dump. I have censored some details as follows:
12.34.56.78 -> SIP provider’s IP (corresponding to sip.myprovider.com)
23.45.67.89 -> My public IP
45.67.89.01 -> Another SIP provider’s IP - not relevant to this call
pbx.mynetwork.it -> my FreePBX box’s hostname
0.0.0.80 -> my freepbx’s natted IP (corresponding to pbx.mynetwork.it)
0.0.0.40 -> my phone’s internal IP
MyProvider -> the name of the trunk this call is coming in on
01234567890 -> the caller’s number
02345678901 -> my PSTN number
91 -> the prefix for MyProvider trunk
[email protected] -> the email address voicemail notifications go to

I can’t put links in posts so here you are:
pastebin.com / grxZvycb

If follow-me is enabled for the extension(s), the FM ring timers will supersede the default settings. Something to check.

Follow me is disabled on both extensions on ring group 600. I tried changing the follow me ring time to 20 seconds but it didn’t make a difference at all. Voicemail still kicked in after 7 seconds.

I think I have found what the problem was though. The ring group had a ring time of 10 seconds, after which it would go to 1000’s voicemail. Increasing that to 20 seconds did the trick.

Thanks to all for your help!