Can't change local networks in SIP settings GUI

We’re running FreePBX and for some reason when we try to remove or add ANY networks through the GUI the fields all go red and there is a red yield symbol at the top right of the Local Networks section that says “undefined” upon mouseover. On the left the Local Networks is also red.

Few things I noticed are we have some duplicates in the list and one of the IP blocks has an incorrect notation with two periods in succession, however trying to change that to proper format doesn’t make any difference upon pressing submit.

Fix is published to edge, upgrade with:

fwconsole ma --edge upgrade sipsettings
1 Like

Tried that and it ran successfully but still getting the same thing. I applied the settings upon logging into the GUI as it appears it needed some update after running this in the console.

I shouldn’t need a reboot or anything, right?

Perhaps you have some input that is not permitted, can you post a screen cap?

We had to roll back to the previous version as it turns out the latest update is causing our calls to randomly have one-way audio issues. Rolling back fixed that problem so I think we’ll wait for a fix for whatever is causing those issues.

Looks like we still have the same issue with the settings in the GUI after rollback but the audio issue is fixed. Attached is a screenshot. Is it OK to modify any networks with invalid characters in the file via the terminal or does that break anything in the GUI? We try to stick to the GUI whenever possible.

Upgrade to edge again. FreePBX 13 does not allow (edit, it does now, bug is fixed!) the subnet mask to be in octets, so everywhere you have change that to just 24.

1 Like

Worked like a charm!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.