Can't access Advanced Settings

I’ve just taken over support of a freepbx system. I’ve got the root and administrator logon and have logged in to both, but i can’t see any menu items to access the configuration.

if i go to /admin/config.php?display=advancedsettings i get Module not found.

i’ve updated the system and i think i’ve updated the modules but it’s still not working.

I believe i’m using FreePBX Has anyone come across this before?

Is it possible that you’re logging into the GUI as a user with limited privileges? Try using unlock to login to the GUI and see if you get something different:

1 Like

That seemed to work. I can see the top menu now. What could be wrong? i’d have thought Administrator would have full rights. I’ve tried to create a new user and got this message.

NOTE: Authorization Type is set to ‘usermanager’ in Advanced Settings - note that this module is not currently providing full access control and is only used as a failover, stop-gap until this pane is fully migrated to User Manager. You will still be able to login with the users below as long as their username does not exist in User Manager

That user has the rights that were granted at time of creation. You can modify either with Admin -> Administrators or under Admin -> User Management.

Thanks for your help Lorne, you nailed it. We’ve managed to create a new admin. One thing we found when creating the admin account was that we had to select either just the ALL SECTIONS access restriction or everything but the ALL SECTIONS restriction to get the menus to show.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.