Cannot restore 15 to 15 backup file from local storage

I am trying to restore a backup that was taken on a FreePBX 15 server to a different FreePBX 15 server. I have moved the file to the correct folder /var/spool/asterisk/backup and I’ve made sure that the filestore has that location listed correctly. When I go to the restore application it says “no matching records found” in the section “restore from local cache”.

I’ve even tried to upload the backup in that same tab but it gets to 99.95 and just hangs. I’ve checked the upload folder on the server and it contains the fully uploaded backup but for some reason this backup never shows on the screen.

Hi @Kafluke

Backup and restore functionality is changed in FreePBX 15 when compared to previous versions. In previous versions restore file used to read the contents of the path you selected and in FreePBX 15 version it read from database so whenever you upload the backup manually from the backend it will not show the file in the GUI.

If you want to restore by manually uploading the backup file from backend then you can run “fwconsole backup --restore backupfilename”.

If you want to upload backup file from GUI and restore then please clear the contents of your “/var/spool/asterisk/backup/uploads” folder and try again. Also please wait until the upload process completes.

I’ll try to restore from the CLI. The GUI upload never finishes and eventually times out.

Hi Kris:

I would upgrade backup/restore to edge (curently and try upload via GUI again. If problem persists open a ticket, we want to nail as many edge cases as we can.

Okay so one issue that I found was that the backup I was trying to restore was in fact a freepbx 14 backup. So it was the last backup that was made before I upgraded central to 15. This showed me that my automated backups haven’t been running since the upgrade. I tried to do a manual backup last night just so I could get all the config and move it over to my new central freepbx 15 server that I just built It failed because no modules had been selected. Okay, I don’t really want modules but I selected them all anyway. Ran for hours (adding .wav files to the archive) and when I woke up this morning it said it had failed again.

In this new backup and restore module I don’t see anywhere to select what you want to backup besides modules. Am I missing something? I built a fresh brand new central FreePBX 15 server from scratch (because of all the issues we’re having with the current one) and now I want to move over all my settings, extensions etc. I’d hate to have to manually export and import all this stuff in one piece at time.

@lgaetz any thoughts. I just need to get the config from central over to the new server

I have performed no tests of partial backup/restores. I have seen cases of both backup and restore stopping before completion, but in all cases there is very verbose output indicating the cause of the error.

Updated both servers (current Central and new PBX using edge repo). Starting the backup on current Central. Will report the logs here. I’m going to select all modules and see if it gets finished.

Says “error backup is already running”. That backup is scheduled for Saturday nights. Yikes!

So here we are 2 days after the backup was automated to run and I’m trying to test only backing up one module and it just says “This backup is already running!” and won’t let me do any backups.

If I click the eyeball icon it says “Log file is missing but process is still running!”

Should I just delete the backup and start over?

Killed the process and then deleted the backup job. Made a new one it it worked fine if I don’t select “call recordings” module. That was timing out trying to add all the recordings to a single backup file.

Nope, still not working. It keeps trying backup call recordings and voicemail even if I don’t have those selected. Ugh.