Cannot receive calls after system updates

I ran a system update last night.
I did a full backup before doing any changes or updates.
Now, I cannot receive calls on my incoming trunk. It just keeps ringing.

If I run watch “asterisk -vvvvvrx ‘core show channels’ | grep channels” I can see that I am getting an error of “Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)”

I have verified that the files exists and that it has proper permissions.

I can, however, make outbound calls just fine.

So, I would like to either roll back to my backup, or get this working ASAP.

I am also getting iSymphony errors, saying that it is not running. I tried uninstalling, then re-installing, but the same results.

One more thing, when I do a fwconsole restart, I get the following:
[[email protected] ~]# fwconsole restart
Running FreePBX shutdown…

RestApps Server is not running
Stopping UCP Server
Stopped UCP Server
XMPP Server was not running
Zulu Server is not running
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] 1 sec
Wanrouter: No valid Sangoma Hardware found, if you have no Sangoma cards this is OK
Stopping DAHDi for Digium Cards
DAHDi Stopped
Running VQPlus Hooks
Stopping Queue Callback Daemon
Queue Callback Daemon Stopped
Running FreePBX startup…
Wanrouter: No valid Sangoma Hardware found, if you have no Sangoma cards this is OK
Starting DAHDi for Digium Cards
DAHDi Started
Running Sysadmin Hooks
Restarting fail2ban
fail2ban Restarted
Updating License Information for 36293114
Starting Asterisk…
[============================] 7 secs
Asterisk Started
Starting RestApps Server…
[============================] 2 secs
Started RestApps Server. PID is 19187
Starting UCP Server…
[============================] 2 secs
Started UCP Node Server. PID is 19239
Running VQPlus Hooks
Starting Queue Callback Daemon
Queue Callback Daemon Started
Running XMPP Hooks
Starting XMPP Server
XMPP Server Started
This product is not licensed

Also, it seems that Asterisk is crashing every time I try to make an incoming call.
The Dashboard gets the alarm.

When I hang up it seems to restart Asterisk.

What would be the easiest way to go back to my backup files? I can do a restore from the GUI, but not sure it it will work since it was on a different version. It was on v13, but a different minor version.

If that doesn’t work, I may be looking at wiping the install, re-installing, then restoring from backup.
???

Another update.
Using the debug, I can see that it cannot connect to AMI.

How can I tell what version I need to install to be able to restore from my backup?
It says 13.0.105 on the backup file name.

And if anyone has a wiki on how to do a fresh install and restore from my backup file, that would be great.

This is your problem. All the rest of the things you’re saying are symptoms of this.

I actually think that asterisk is crashing continuously, so it probably would be best to just stop freepbx (‘fwconsole stop’), make sure no updates are half-done (‘yum update’), run a chown (‘fwconsole chown’) and then reboot your machine.

Thanks. I did the yum update but nothing was marked for update. I did the chown and rebooted.

I am getting a lot of the “CRITICAL] (admin/bootstrap.php:270) - Connection attmempt to AMI failed”

Also, when it came back up, I tried to call in, and got the same error above again, and Asterisk crashed and restarted.

I may have to go in tonight, do a clean install, and build the system again. Not what I want to do, but I may have to if I can’t get this figured out.

Anything else I can try?

Thanks
Jason

By whatever means get another version of asterisk, FreePBX is not crashing, just asterisk, explore /var/log/messages for a clue.

I am going to see if I can look at those logs. Attached is a zip of my system info if someone doesn’t care to take a look. I would really appreciate it. support-tu1ruq.tgz (77.2 KB)

It looks like I have the entry below multiple times when I try to call in.

Feb 5 16:42:41 localhost kernel: asterisk[7609]: segfault at 18 ip 001f2167 sp b5a7cf20 error 4 in libasteriskpj.so.2[18b000+11f000]
Feb 5 16:42:53 localhost kernel: asterisk[10370]: segfault at 18 ip 0024b167 sp b5b7df20 error 4 in libasteriskpj.so.2[1e4000+11f000]
Feb 5 16:43:05 localhost kernel: asterisk[10539]: segfault at 18 ip 001f0167 sp b5ae5f20 error 4 in libasteriskpj.so.2[189000+11f000]

Take a look at this thread issue seems similar

I would stop using pjsip until it is totally stable

Thanks everyone for your help on this. It looks like the yum remove asterisk13-res_digium_phone fixed my issues and cleared everything up. I appreciate it guys.

I was prepared to rebuild the entire system overnight tonight.

Thanks again.