Can Not Connect to Asterisk

Hi all,

I’ve a lengthy concern, thanks a lot for sparing your time.

I’m doing mobile software development post graduation in an University, I’ve VoIP android app to be built as my project. My Project has to assign a virtual number to the user from which he can do outgoing, incoming call and also messages.

For this i’ve done lots of research found Asterisk+ freePBX for the communication tool and DID numbers for assigning the number to the user.

After Installing Asterisk, freepbx i’m getting “can not connect to asterisk”. I tried on cent os 7, debian 9, Ubuntu 18 by following freepbx and computingforgeeks documentations, for all of them i’m getting the same issue “Can not Connect to Asterisk”.

Doing some research found that lots of people posted the same issue, i tried each and everyone of them but not succeeded. Most of the answers suggested to check “/etc/asterisk/manager.conf” with “etc/amportal.conf” for the user access. I’ve the same user access in two files:

/etc/amportal.conf =>


tried changing to my server ip in permit.
when i’m doing “fwconsole restart” getting an error like “Core FastAGI Server is not running”.

Please guide me where i was going wrong , First of all for building an VoIP app is this required to do.

Thanks a lot again for sparing your time.

The FreePBX Distro won’t work for you?

I’m installing on VPS Server, it doesn’t allow other OS

A KVM VPS can run any OS and will boot the FreePBX ISO.

is IMO a quality house.

Or, find a lower cost provider at
Click the Virtualization icon and find the cheapest KVM with sufficient memory, etc. These servers are often oversold and will have occasional voice quality issues, but should be adequate for a student project.

Thanks Stewart, i’m able to upload ISO in VULTR.
Will try that too

Thanks Again Stewart

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.