Can not connect to asterisk using 4g connection

i installed asterisk and freepbx on centos 6 follow your guide.

If i try to connect with my iphone using a softphone i have problem if i use my 4g connection.
If i use my wifi connection i have not problem.

How is possible?
What i can change?
Thank You


If you use your 4g connection it means that you are accessing your PBX from the Internet.

Did you?

  • Use the address your PBX has on the Internet or the address it has on your local network? You should use the address it has on the Internet; If it is not static you will have to use one of the dynamic DNS sites…

  • Open the appropriate ports on your router/firewall and forward them to your PBX (if you only have one IP)?

If this is a home network your phone has an IP on the same network as the PBX so there is no firewall involved, no need to know your PBX Internet address…

See above and give us more information if you still need help…

Good luck and have a nice day!


hi, before i thinked i solved, but is not so.

This is the problem:
My asterisk is on a cloud server so i can connect using him ip address

With the extensions in my office i have not problem

If i use my iphone with media5-fone app and i use wifi i have not problem
If i use my iphone with media5-fone app and i use 3g or 4g connection i have problem
The problem is: microfone work, headphones not work

I not hear other extension, but this other extension hear me…

How is possible that? Maybe i have to configure somethink in the extension or in advanced settings?

can someone help me?

I am sure your provider is blocking it. For example Verizon blocks SIP on their networks

is not so because i have 2 server with the same configuration.
One server work with my 4g connection, second server not work.
I want use this second server because the first give me always some problem when i apply change during an edit

the same problem i have if i make a call from 2 extension, for example from 104 to 105
With wifi work, with 3g not work…

I’ve been a long-time Verizon subscriber and I’m not sure this is completely correct, although I haven’t tried it lately. I don’t think they block SIP, per se, but I do think they might block port 5060 in specific markets. I’ve tried connecting to my test server over my Verizon phone over SIP in the past and had no trouble, and can do it with alternate SIP ports (like 5061 and 5160) and IAX2. I don’t expose port 5060 to the Internet (except to really specific hosts) since it invites script kiddies, so port 5060 isn’t really an viable piece of the puzzle for me at this time. I know; it’s a pretty pedantic point, but I thought it might become important here in a few responses.

Just so we’re all working from the same sheet of music:

  • 3G and 4G are data transports that your cell phone uses to make calls and transfer data. If you can connect to Internet sites over your “data network” (and not WiFi) then your data should be making it to the server. The connection (when coming in from your 4G connection) will always show up on the external network interface (this is what @Marbled pointed out).

  • WiFi uses a different connection - usually through a WiFi Access Point in the local network. Since the WiFi connection is almost always through your local connection, the connection will be coming in through your local addresses.

This difference alone is enough to make it challenging for this type of connection to get started. There are LOTS of places where this can be going badly, and the particulars of the solution depend on a lot of things that YOU control and that WE don’t have any insight into.

To continue helping you troubleshoot this, we will need to know (as a minimum) several things:

  • How is your server connected to the Internet?
  • Does your PBX have an external (Internet routable) address?
  • It’s usually safe for us to assume that your server has a local (non-routable) address if you have extensions. let us know of that isn’t the case.
  • Do you have a firewall in the circuit?
  • Do you have your firewall set up to pass the ports you are using for all of the necessary traffic?
  • How many of the PBX servers are in your local network?
  • If they are in the same network, how do you have the port forwarding set up on your firewall
  • Are you running the FreePBX distro, or did you “roll your own”?
  • Have you thought about adding a VPN connection for your “external” phones?
  • Version of Centos?
  • Version of Asterisk?
  • Version of FreePBX?

hi, now i try to give you more information.

My server is a cloud server located in a webfarm here in italy.
I can connect via ssh using ip address.

Freepbx version is: FreePBX
Asterisk version is: 13
Server have centOS 6 64 bit

I not use e vpn on my phone

The server is connected by a cable (i think, is not in my office).
But all that is strange because with the old server i can use my 3g connection, so i think i need to add some configuration in the freepbx control panel.

maybe i solved it

the extension for mobile, in the “nat” section i had “no” and not worked. Now i change with “comedia” and he is working…
Which the difference for all the items in the nat section?