Calls from Trunk provider recorded as from unrecognised peer

We have a freepbx 2.11 system which is up and running, however I have noted in the logs that calls routed from our VoIP provider are marked as coming from an unrecognized peer. We use a registration string in the single trunk configured. I’ve confirmed that calls can come from any of 11 ip addresses.

How do I get Freepbx/Asterisk to recognize that the calls come from our VoIP provider? We have the host and domain configured with the same host used in the registration string.

Yet another thing I had to do to work with Windstream - they liked to initiate from a different IP even though it was a registered trunk.

Simple fix - create Inbound trunks for the IP’s they are sending to you from with the IP as the Host and don’t require auth (username/secret).

It is a little insecure since someone could masquerade as that IP and be allowed in, but set all the trunks as context=from-pstn and you should be fine.

So, here is what it looks like in the trunk Setup:

Peer Details:

Leave the User Details blank and make sure it’s not specified in any outbound route.


Thank you for the reply. I have been going through numerous documents/web pages to try and figure this out.

No problem - it took me a while fighting with them because it’s kind of counter-intuitive, but it works and I never had any problems with it once it was working.

Well I tried the changes on one PBX system (FreePBX 2.11) and that worked first time. I tried the same procedure on another PBX system (FreePBX 2.12) and none of the trunks would register.

Any ideas?

Apart from the username and registration string the details were all the same.

No, the trunks for the other IP addresses do NOT register - only the main trunk registers - they are there just to absorb the calls from the foreign IP’s