CallerID not being set correctly


Can anyone help me to identify why my outbound CID is not being displayed? Instead it is always the main number of the company:

Extension setings:

Trunk settings:

Logs look like the extension CID is being set:
– Executing [[email protected]:12] Set(“PJSIP/0000-000003a6”, “USEROUTCID=0911XXXXX”) in new stack
– Executing [[email protected]:13] Set(“PJSIP/0000-000003a6”, “EMERGENCYCID=”) in new stack
– Executing [[email protected]:14] Set(“PJSIP/0000-000003a6”, “TRUNKOUTCID=0911XXXXX”) in new stack
– Executing [[email protected]:15] GotoIf(“PJSIP/0000-000003a6”, “1?trunkcid”) in new stack

The SIP trunk goes to a Vega geteway which dials out using the calling party id:

Can anybody confirm if I am missing something obvious? When previously all working over ISDN this worked fine and showed the correct ID.


I don’t understand. Did you change from ISDN to another protocol? If your lines are now analogue or ‘dumb’ E1, control of outbound caller ID is not possible. With PRI you should be fine, but may need configuration changes in the gateway or at the carrier.

Or are you just saying that it used to work but doesn’t anymore?

We have changed from ISDN to SIP.

We are using a Vega 200 Gateway to convert ISDN --> SIP to connect our PBX to the ISDN 30 PRI lines.

You have not changed your service. You have simply converted how you connect to it.

When it leaves your premises, it is old school ISDN/PRI or whatever. You are bound by the restrictions your carrier has on that.

At the Asterisk command prompt, type
pjsip set logger on
and make a test call. You will see the outgoing INVITE from the PBX to the Vega. Confirm that the P-Asserted-Identity header has the desired caller ID in the correct format.

If not, a complete log of a failing call should show why it is not being properly set.

If the PAI header is correct, then the Vega is likely not processing it properly. I know nothing about the device but assume that you can enable some logging to see the Q.931 sent out. If the caller ID there is correct, you will need your carrier to fix the problem. Otherwise, check the gateway configurations to see why the number is not being propagated.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.