Caller ID problem, inbound calls show IP address as phone number after module update. Started around 9/10

callerid
bug
Tags: #<Tag:0x00007ff2e70c96a8> #<Tag:0x00007ff2e70c9450>

(Lance M) #1

Hello, I am having an odd problem.

All of a sudden one of my inbound numbers is sending my server IP address as the telephone number in the caller ID.

This is only happening on the one inbound number.

Here is the kicker, the calls are still going into the recording folder with the correct caller id.

I use Caller ID Superfecta on both.

In the yealink under callerid it shows
[[email protected]] on the one where there is the problem

On the other DID where it works it shows (I have changed the number to 555-555-5555 in this post only it actually shows the real number)

[[email protected]]


(Sholinaty) #3

what are your devices set to use for their callerID formats and sources?


(Lance M) #4

the devices use the pbx for the caller id, it only happens with one inbound DID, the other inbound DID works perfectly.

This just started to happen, it was working perfect for three years.


(Sholinaty) #5

“uses the pbx for the callerID”

thats…

From? P-Asserted-Identity? Contact? Remote Party?

Which header is your device choosing to read for callerID?


(Lance M) #7

Here is when I set sip debug on:

Here is the non working I have replaced any sensitive numbers with X

INVITE sip:[email protected]:5160 SIP/2.0
Via: SIP/2.0/UDP 64.154.41.158:5060;branch=z9hG4bK57e34254;rport
Max-Forwards: 70
From: “+1402XXXXXXX” sip:[email protected];tag=as20fb4412
To: sip:[email protected]:5160
Contact: sip:[email protected]:5060
Call-ID: [email protected]:5060
CSeq: 102 INVITE
User-Agent: FPBX-2.11.0(11.6)
Date: Tue, 28 Sep 2021 22:45:59 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Content-Type: application/sdp
Content-Length: 314

I don’t think it is a problem with the SIP header as the Caller ID Superfecta is getting the name right when it looks it up. The problem is from when it passes it on after this.


(Jared Busch) #8

Are you certain that you enabled the Superfecta on that inbound route?


(Lance M) #10

I can’t figure out why it would drop that though.


(Lance M) #11

I resolved this and boy do I feel dumb. Sometimes it is the easiest fix but we look for other resolutions.

It was a DNS problem.


(Lorne Gaetz) #12


#13

Or maybe,

It looks like a DNS probem,

Yes but that’s an easy fix, give me a few hours … .

(days pass) If it’s still broke, maybe it’s a BGP problem ?

No way it’s a BGP problem,

Then what is it?

Don’t know yet, it might take a week or two to find out . . .

No prob, Let me explain that to my clients, I’m sure they will understand.

(Sorry, off topic, but on point :wink: )


(Lance M) #14

I might have spoke too soon, the bug is back trying backup and restore.


(Lance M) #15

OK So I thought I had the problem fixed.

I finally gave up and reinstalled a fresh install of FreePBX and then ran a backup restore.

Everything was working perfect. I ran a module update and then the problem returned.

So the call logs in the database correctly, the call recording shows the proper number. What the phone shows is the Name from the superfecta but the telephone number only shows the IP. On the soft phone (Groundwire) it is blank.

Here is what the CDR looks like before the problem:

Sat, 31 Jul 2021 13:33 CHAN_START +14026896923 4026896923 DEFAULT 4802100299 from-pstn SIP/ [2945726824-000002b4
Sat, 31 Jul 2021 13:33 APP_START +14026896923 4026896923 4026896923 4802100299 DEFAULT recordcheck sub-record-check MixMonitor SIP/ [2945726824-000002b4
Sat, 31 Jul 2021 13:33 APP_END +14026896923 4026896923 4026896923 4802100299 DEFAULT recordcheck sub-record-check MixMonitor SIP/ [2945726824-000002b4
Sat, 31 Jul 2021 13:33 APP_START Tanya Schmidt 4026896923 4026896923 4802100299 DEFAULT 300 ext-queues Queue SIP/ [2945726824-000002b4

NOW it goes blank at CNUM after Mix Monitor

Tue, 5 Oct 2021 21:59 CHAN_START +14029437619 4029437619 DEFAULT 4802100299 from-pstn SIP/ [2945726824-00000000
Tue, 5 Oct 2021 21:59 APP_START +14029437619 4029437619 4029437619 4802100299 DEFAULT recordcheck sub-record-check MixMonitor SIP/ [2945726824-00000000
Tue, 5 Oct 2021 21:59 APP_END +14029437619 4029437619 4029437619 4802100299 DEFAULT recordcheck sub-record-check MixMonitor SIP/ [2945726824-00000000
Tue, 5 Oct 2021 21:59 APP_START Lance Molina 4029437619 4802100299 DEFAULT 300 ext-queues Queue SIP/ [2945726824-00000000

(Lance M) #16

Now I don’t think it is a DNS issue, I gave up and did a fresh install, everything was back to normal… Then I did the module updates and poof back to the problem.


(Sholinaty) #17

very odd. i’d almost suggest doing the module updates 1 by 1 (or at least maybe the key modules 1 by 1) to try and narrow down which module is affecting this