Caller-ID on phones is missing the "1" prefix ... how can I force a "1" to prefix all caller-id #'s ?


I am running FREEPBX with a SIP carrier that delivers “+1” to all domestic US inbound calls. The “+1” is most likely being stripped out of the inbound calls, because all of the Caller-ID on every handset (Polycoms) has just 10 digit area code + phone number (NXX-XXX-XXXX).

I either want to force a “1” before all Caller-ID phone #'s delivered to all handsets, OR adjust the stripped “1” out of all numbers so that it only strips the “”.

I’ve tried adjusting the extensions.conf so that it’s not stripping the “1” and all phone #'s stopped working until I adjusted it back, so I assume that if I take out the “1”, I’ll have to adjust all inbound DID’s and I don’t want to do that.

What’s the best way to fix this?

The real issue is … whenever a user tried to redial from history, without the “1”, the dialed number does not dial. I already have a matching pattern for “NXXXXXXXXX” and “1NXXXXXXXXX”…still can’t dial without the “1”.

Help is appreciated, thanks!

There’s a context in /etc/asterisk/extensions.conf called “something-e184-*” that modifies the inbound Caller ID and processes the incoming CID in several ways. You can replace it by adding it into the “overrides” config file and changing the specifics to do what you want.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.