Call Waiting Missing Under Feature Codes Module

The user guide states that call waiting “settings are controlled in the Feature Codes module, Extensions module, and Advanced Settings module”. I have an extension set up with an analog phone attached to a Grandstream HT503. The HT503 in this case acts as a conduit between the analog phone and the PBX (RASPBX to be more specific). The HT503, being both an FXO as well as FXS device also acts as a conduit between a POTS line and the PBX as well. All of this functions very well with the exception of Call Waiting.

Call waiting is enabled for the Extension (and the Extension page shows this) and CW is enabled in the Advanced Settings page. The Feature Codes page, however, does not show the Callwaiting section as indicated in the user guide.

I do not have POTS call waiting and realize that if I am on a POTS call that another call to that POTS line will result in a busy signal for the caller. What I am looking for is to be notified of an incoming POTS call if I am on a digital call or be notified of an incoming digitial call if I am on a POTS call. The current setup sends the call to voicemail which is acceptable but not preferable.

I am unsure as to whether the lack of these settings on the Feature Codes page is due to the use of an ATA or some other setting that I must modify. Hopefully someone here can point me in the right direction.

I found that I actually do have call waiting working with the setup I described it is just that my test was evidently flawed, however, the Feature Code Module still does not show the settings so I will leave this issue open.

As far as my test is concerned I tested by calling out through the PBX using my Google Voice number and back in through my POTS line which went to voicemail every time instead of signalling that there is a call waiting. I do not know why that does not work (maybe someone can explain it to me) but I thought about that testing method and realized I probably should have a totally independent call come into the POTS line that is not already somehow associated with my PBX.

I then called from a different Google Voice number I use from my Android Phone into my POTS line while I was already connected to my wife’s GV number on her android phone which I had called from our PBX. That did the trick! Not only did I get the call waiting indication noise but my phone displayed that it was coming in on my POTS line (which I have set up on the PBX to just show the name of the service provider since I don’t pay for caller id). I was then able to toggle back and forth between the calls using the Flash button on the phone.

Though I am relieved that call waiting functions perfectly for my scenario I am leaving this issue open as the settings are not showing up on the Feature Codes module page.

I just checked my FreePBX 13 system and the codes (*70 and *71) are both there under the Call Waiting heading.

Is the Call Waiting module installed? Admin, Module Admin.

Thanks for the reply Dave. What operating system are you running? I’m running in Raspbian (linux) on the Raspberry Pi. Don’t know if operating system makes a difference. Could you be a little more specific on the version of FreePBX you are running? I’m running version Maybe yours is newer (or older)?


The user guide states “There is no “Call Waiting” module in the GUI menus. Instead, call waiting is managed through the Feature Codes module, Extensions module, and Advanced Settings.” Call waiting is actually working for me now but the Feature Codes page is not displaying the “Callwaiting” section the user guide depicts where the Code and Actions should be available for modification. When I look at Admin, Module Admin there is no “Call Waiting” module but there is a Feature Codes module and that whole scenario fits the description outlined by the user guide. Please let me know if there is something I am misinterpreting here.

You need to install the call waiting module as Lorne said. That will show you the feature codes. Call waiting still works because the core code for it is in the core module. Simple check online for call waiting and install it.

Some modules don’t show up in the menu GUI but they are still modules.

fwconsole ma downloadinstall callwaiting


Thank you for the clarification. After reading your post I went back to the Admin, Module Admin page and noticed there was a “Check Online” button so I clicked it and it brought up a nice listing of what I didn’t have installed as well as what could be upgraded. I downloaded/installed the Call Waiting module and upgraded all the ones listed as available for upgrade (hopefully that was not a stupid thing to do). Anyway, I now have the Call Waiting options available on the Admin, Feature Codes page.

Thanks again!


I apologize that I didn’t look closely enough on the Admin, Module Admin page to see the “Check Online” button used for installing additional modules. It might be beneficial to have clarification in the user guide concerning the need to add this module vs the current explanation indicating that there is no Call Waiting module although I may be an isolated case being the dummy that I am. As complex as FreePBX/Asterisk is I am surprised I even have it up and running and that it works so well. I guess that is a testament to the developers and everyone else who has been involved in it’s evolution. Thanks again for your reply and I’ll try to be more thorough in researching issues in the future.

1 Like

Module Admin user guide has lots of detail:

Call Waiting module is installed by default, don’t know why it wasn’t for you. Added a small note to wiki for clarification.

Raspi, they don’t include many modules.