Call Parking / Yealink T46S

PBX Version:
PBX Distro:
Asterisk Version:

Yealink T46S

I have other FreePBX Systems out there using Yealink T46 phones. They are running older versions of FreePBX and they are T46 phones and not the T46S.

On the other systems I have two buttons programmed with BLF’s set to 71 for the Value and Park 1 for the label and ** for the extension. On that system when you are on an active call all you need to do is press the BLF and the call parks directly on that button for 71 and the light turns red as expected. Anyone can pickup the call by pressing that BLF and the call is connected as expected…

Now I have this new system with the versions described above. When on an active call if you press a BLF configured the same way on a T46S the call is not placed on park and disappears from the system, although the call is not dropped from the originating caller and I cannot find a way to bring the call back.

As a workaround which I do not like we have assigned a park button to the phone by setting a line key to type DTMF and sending ##71#. I we have another button set as a BLF with the value 71 and label of Park 1. The BLF then is red when a call is on park.

I would really like the original expected behavior of just assigning a BLF to 71 and the person can just press that button to park the call and the button then turns red. To retrieve the call simply push the red button.

I have tried to upgrading the firmware in the phone and no lock, having the same issue.

Any ideas or a resolution work be greatly appreciated.


As I understand it you need to transfer the call to your parking lot extension, which is by default 70. Then the parking function will automatically put the call on the first available slot.


Did you know about: the sort-of newer feature for parking on Yealink phones? They added this to the firmware about a year back or so.

Not sure if it the direct or best fix, but here is the information:

Once logged into your Yealink phone UI (GUI): go to:
Features → Pick UP & Park

Change Call Park from Disabled to Enabled
Put in your Call Park Code: 70
Put in your Call Retrieve Code: 71

When a call is active: Press the MORE softkey, and you will see the options to PARK (dedicated softkey button).

Maybe this might help you.

I just tried that and that is not working either. I am not really sure why this is so complex. I have used plenty of Yealink phones in the past and have not had this issue.

I just want two BLF buttons Park 1 and Park 2. In the past I just created the BLF on the phone and set the value to 71 and the label to park 1 and another button value to 72 and label park 2 and it just worked.

Check the firmware on your Yealink SIP-T46G phones.
As you know: they are discontinued now.
Only the SIP-T46S is still alive (in production).

The last and only firmware you should have on a SIP-T46G is:

If the phone is not using this FW: upgrade it because this is the best one of the breed.

Register your SIP-T46G with the 71 and 72 set (to another) FPBX system. Test the phone on a different system with working parking to see if it is the phone and/or the PBX … (as a starting point).

Bump, nothing sugested so far has worked. Anyone have any ideas on how to get parking working on the T46S?

I don’t know whether this is relevant for your device, but on my ancient T26Ps, in DSS Key → Memory Key, I set the Type to Call Park (not BLF) and the Value to (for example) 71
Is there an equivalent on the T46S?

Interested in this as well. I have just been setting up direct park because the call park function stopped working properly. I would press call park, the call would park on 71 and turn red, but then the call park button would stay red. This only allowed one call to be parked using the call park button. Parking directly to 71, 72 fixed this but for busy PBXs it can be hard to manage.

I agree with you, this is obviously a bug and parking is very broken in 15. I am either going to try and upgrade to 16 or build a new machine with 16 and migrate over. It would be great to have a real supported ptach or fix for this.

It has been an ongoing issue for me since at least 2017 so probably Freepbx 13, 14, and 15 so I have kinda given up on it working that way again. Direct parking works well enough for me most of the time. I know some people make a visual parking to use with an XML button. I do not have any up to date code to try though.

This actually worked for me on a T46U. I decided to give it a try. I will have to try on some T46S and see if it is the same.

T46U firmware:

Thank you.

@defres I am unclear on exactly what your parking issue is.

I have both a T46G and T46S sitting next to me and I can test something if you can be more clear on exactly what scenario is not working.

I know you said direct parking was normal, but I got lost in the back and forth on what you want to work in what manner.

All we want is to be able to setup a couple buttons on the phone labeled Park1 and Park2. When you press Park 1 the call is actually parked on 71 and park 2 72 respectvlly, When a call is on the phone in a line button press the Park 1 or Park 2 (if Park 1 is in use-BLF RED). Anyone should then be able to press the Park 1 or Park 2 on any phone in the company and if there is a call parked there (red BLF) then pressing that button would pickup the call on that extension. This used to work this way and it no longer does.

Can you please elaborate on what exactly happens to the call? Can you please post a call trace via pastebin?

Assuming you are on anything close to current, your described need is the default behavior for a Yealink Phone connected to FreePBX.

The key type BLF with a value of the parking slot number will blind transfer an active call to the parking slot. Pressing said BLF when a call is parked will retrieve it.

If this is not what you are experiencing, then you have changed some default someplace, or you are on an very old version of FreePBX,

If the process works, but sometimes the BLF does not seem to turn red, then reboot all the phones and see if the status likes go back to normal working condition.

This has been resolved by using version 16. For some reason it will not work properly in 15.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.