Call Park - Single Button Using Dsskey

Current PBX Version:
Current System Version: 12.7.8-2208-2.sng7
Phone: Yealink T46G, Firmware Version:

Greetings folks,
After trying everything I can dig up on the interwebs and testing different settings I cannot seem to get a T46G to park a call and then retrieve it using a single button. If I set up a Dsskey as a ‘Call Park’ OR as ‘BLF’ with the value of an existing parking lot It DOES show the green status on the phone and it will retrieve a call out of that lot however, it will NOT park, if I am on an active call and hit the button nothing happens and the asterisk full log file shows nothing happening, I can hit it 10 times with no effect, if there is no active call and I hit the button it tells me ‘I am sorry but there is no active call on that extension’, if there is a parked call on that parking lot then it picks up the line as expected… I have tried different call park settings on the phone under ‘pick up and park’ - FAC / Transfer and just cannot get this simple function to work. Are there any other settings on the T46G or in FreePBX that would stop a BLF from parking into an extension? The phone has been reset to factory and updated to the latest firmware- I am on the latest version of freepbx 16 and fully updated.

100% a phone config. You have Blind Transfer or Semi-Attended transfer enabled? If you are only using Attended you need to transfer it like an attended transfer. I use Blind as the default and it parks the call immediately.

My xfer settings on an old T26P:

DSS key set to Call Park with value 71.

I have tried both blind(default) and attended. I have tried those two settings with every combination of FAC/Transfer and the Dsskey options for ‘BLF’ or ‘Call Park’… I have been using freepbx for 10 years and I have never been able to do anything more than DTMF ##70# and then monitor the parking lots with individual buttons (I hate this, its confusing for people and I am done trying to train people). There has to be a base file option that is not set or something because it literally just will not park the call with most of these settings, I think with FAC and the call park code set it will actually dial whatever you put in the field and then add the ‘Value’ to the end of that string but its a total loss, in that scenario it says the extension is invalid…

If you are using ##70# to park calls, the BLF key should show Call Park 71 and another with Call Park 72, etc. You need one park button for each slot you want to use. I don’t know what 11 is in your case. That gives you one-touch park and retrieve for each monitored slot.

If you have set up more than one parking lot, this suggestion may not apply.

Forget the ##70# that is the old way of doing things… This is a test phone. I have 2 keys setup because ‘Park Call’ does have some weird interactions with different settings on the phone. 11 is just a parking lot… Either of these buttons should park the call into that parking lot yes?

I do not have Yealink phones but on my phones, I use the BLF/Xfer keys and simply put the parking slot number. It works flawlessly on FreePBX 15 and FreePBX 16. I think in your case, using the call park button to put it in the slot may not work. Instead use the information in this manual for the Yealink regarding transfer via BLF/DSS. You simply put the parking slot (not parking lot) number on the key.

The Yealink T46 manual explains the use of the DSS key vs. the BLF key. Beyond that, I cannot understand why this is not working for you unless there is something obscure when you have more than one parking lot. I’ve never used multiple parking lots.

Correct, 11 is what you called a ‘slot’. I have 1 parking lot (10) with 5 slots starting with 11,12,13,etc…
There are others that have had issues with these phones not parking with BLF or Call Park selected.
Maybe its time to switch but I have one office with 30 of these things lol.

As popular as the T46 is, it is hard to imagine there isn’t a way to make it work. Perhaps someone with this phone will reply.

I can confirm that it works on Aastra, Grandstream GRP series and Fanvil phones.

What version of FreePBX are you running on your system and what firmware version is on your Yealink phones. This discussion in FreePBX seems to indicate there is an issue both with firmware version on the phones and also with older FreePBX versions. Apparently, FreePBX 16 solves the issue.

Also, you may have to put the parking slot extension 11 in the “Extension” field on the BLF key.

I opened this thread because that one said the issue was fixed in 16 and it closed… I am on Freepbx 16 and my firmware on the phone is It is the most recent from Yealink per their support site.

Well I am in the middle of the woods right now but when I get home I will post my configs. I do this with numerous locations and it works just fine having 1 touch park/pickup.

I appreciate any help I can get on this one, I am out of ideas and settings to try!

My reply in How to enable transfer DIRECTLY to parking SLOT - General Help - FreePBX Community Forums

EDIT Again, I’ve done too many threads for this. So there may have been a step missing here.

transfer.dsskey_deal_type = 2 << This is the real magic sauce here, I’ve said in other threads the DSS Key transfer mode must be Blind I thought that was already set in some of these but might not be.

Then it’s just: (I use 1-10 as my slot numbers instead of 71-79)

linekey.6.label = Line 1
linekey.6.line = 1
linekey.6.type = 16
linekey.6.value = 1

Hello @BlazeStudios,

Thanks for sharing the info. I still seem to be missing something.

I have disabled semi-attended transfer.

I believe I’m supposed to use BLF for the DSS Key config. In my case the users want to blind transfer a call to 1 of 3 defined parking spaces, they then tell others in the office where they put it.

I have asterisk setup with 70 for the parking lot extension and 3 slots starting at 75.

If I choose BLF, it seems I need to define a value and an extension on my T46s, I’m confused which values need to go in each of those fields. Appreciate any clarity you can share.


  1. Set Line Type to BLF
  2. Value = Parking Lot Slot
  3. Label = Display on the phone
  4. Line = The account to use (generally 1)
  5. Extension = I leave this blank

Thanks for the quick reply… That’s what I have so I seem to be missing something?

When I hit Park 1 from the phone, the call transfers but the light remains green and if I try to pick it up in that parked slot (hit that button again from the same phone or a different phone), it rings that extension (75 in my testing) and tells me no call is parked.

Just to confirm, you are hitting the Park 1 to park the call while the caller is still on the line?

At this point we would need to see a debug from the system to confirm the call is being parked. You’ll need to provide a call that you attempt to park but the button never changes.

Correct… I’m calling from my cell, I pick up, confirm there’s a connection, and then I hit Park 1 (should send them to 75). The “Park 1” light remains green, though the call transfers from that desk phone. My call is still active on my cell side, I am lost in the nether or upside down world. :slight_smile:

Let me track some logs, I just wanted to be sure I was configuring it correctly, which seems to be the case.

I am curious though… in FreePBX it tells me 70 is the park extension. I’ve set my lots to begin at 75 through 77. Is there some other value needing passed or is that encoded in the BLF function? Just wanted to make sure I wasn’t missing some other function.

I saw @sawgood1000 suggested using the new Park feature in the t46s, but the method you’ve outlined is how they are trained to use it today so I’d prefer to stick with that option if I can.

Let me do some logging.