Calendar Authentication Type, NTLM

Hello! I was having an issue a few months ago with getting my Calendar module to authenticate with EWS. The returned response was “401 Unauthorized,” which from what the community told me was just a bad password or cert - basically that Microsoft was responsible for sending the error code. Makes sense, but doesn’t help me toward a resolution.

This week, one of my team decided to dig in for a few more hours, and found that it is related to the NTLM authentication attempts. By changing the line in /var/www/html/admin/modules/calendar/vendor/jamesiarmes/php-ntlm/src/SoapClient.php that reads:

we were able to get successful authentication and use our calendar module again. I started looking for a possible fix on this on the exchange side (maybe I can ignore NTLM requests?), but so far have been unsuccessful. Disabling NTLM seems to be a big deal with far reaching consequences.

Perhaps my best route would be a feature request to add “authentication type” as an option on the FreePBX calendar configuration module? I don’t want to have to patch this file every time I update core.

1 Like

I would say you should take the route of paid support, tell them your findings, they might come up with a better solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.