Bulk Extensions with latest version of Trixbox

Hi all,

I downloaded the latest ( 0.1.1) version of the Bulk Extensions last week and installed it on Trixbox 2.6.0.7, all worked fine first time, did what I wanted super !!!
Yesterday I installed ( on a clean machine) the new version of trixbox, 2.6.1 and installed the same version of BE on it, it installed fine and activated OK, but when I tried to import a CSV file ( even the sample in the install tar) I am getting run time errors.
Has anyone else tried this and got it working OK ? if so How ? The reason I upgraded by the way is that I wanted to get FOP to work which it seems to be just fine now.
Cheers

azmerlin,

I’m glad you got some use out of Bulk Extensions.

I don’t use trixbox, so I can’t really comment on any troubles with it. Bulk Extensions uses core FreePBX functions to modify extensions, so if the latest trixbox release made any changes to those functions, I would expect errors.

I am about to release 0.2.0, so please let me know the details of your problem. If a fix is needed, I should be able to role it in with the new release.

Thanks, Seth

Seth:
This is exactly what I’ve been looking for to mass create extensions… it takes care of 1/2 of the provisioning task!
You Rock!

Anyone know if there is something that will Export extensions?

Well it seems to work OK, but when I try and load a CSV ( the included sample) I get the following error:
Runtime Message
An error was detected which prevented the loading of this page. If this problem persists, please contact the website administrator.

Undefined offset: 1

Error occurred at line 89 of controllers/index.php.

Stack Trace
/var/www/html/framework/system/core/Kohana.php [268]:

Thanks

azmerlin,

The errors indicate that you used the trixbox Bulk Extensions module by selecting PBX and then Bulk Extensions from the main trixbox menu. This is a new module made by trixbox, not the existing module with the same name for FreePBX. Don’t let that make you think that they are nearly the same, though. The trixbox module allows you to add extensions with up to 6 settings specified, while the FreePBX module allows add, edit, or delete extensions with up to 60 settings. That is why the sample CSV file from the tarball didn’t work.

I believe you can start the FreePBX Bulk Extensions module in trixbox by selecting PBX and then PBX Settings from the main trixbox menu. This brings you to the FreePBX interface (the so-called PBXconfig). Select Tools from the left side menu. Then select Bulk Extensions under Third Party Addon from the left side menu. Please let me know if you have any problems loading the CSV from that page.

By the way, as originally suggested by wiseoldowl, the 0.2.0 version of Bulk Extensions will include a full Export function for all extensions. That should make it even easier to make a good CSV file. I’m also working to include some additional documentation.

Thanks, Seth

Hi!

i am searching Bulk Extensions version 0.2.0, but didn’t find where i can download this module. Can you help me?

Sorry for me English.

Download the tarball with the following link:

http://freepbx.org/trac/browser/contributed_modules/release/bulkextensions-0.2.0.tgz

Then use the Module Admin page to load the tarball into FreePBX.

Thanks, Seth

Hi.

When i press export, i got:

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 283

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 284

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 285

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 286

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 287

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 288

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 289

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/admin/modules/bulkextensions/functions.inc.php:309) in /var/www/html/admin/modules/bulkextensions/functions.inc.php on line 290
action,extension,name,cid_masquerade,sipname,directdid,didalert,mohclass,outboundcid,ringtimer,callwaiting,emergency_cid,tech,hardware,devinfo_secret,devinfo_channel,devinfo_dtmfmode,devinfo_canreinvite,devinfo_context,devinfo_host,devinfo_type,devinfo_nat,devinfo_port,devinfo_qualify,devinfo_callgroup,devinfo_pickupgroup,devinfo_disallow,devinfo_allow,devinfo_dial,devinfo_accountcode,devinfo_mailbox,faxexten,faxemail,answer,wait,privacyman,record_in,record_out,vm,vmpwd,email,pager,attach,saycid,envelope,delete,options,vmcontext,vmx_state,devicetype,password,noanswer,devinfo_immediate,devinfo_signalling,devinfo_echocancel,devinfo_echocancelwhenbridged,devinfo_echotraining,devinfo_busydetect,devinfo_busycount,devinfo_callprogress,devinfo_notransfer edit,100,temp,default,0,enabled,sip,52346432,rfc2833,no,from-internal,dynamic,friend,yes,5060,yes,SIP/100,[email protected],default,0,0,0,Adhoc,Adhoc,disabled,fixed,

Hi volk22,

Can you please indicate what software you are using? For example, Asterisk version and FreePBX version. Also, if you are using a specific distro, please mention which one (Elastix, PBX in a Flash, trixbox, etc) and its version.

Thanks, Seth

I am using Trixbox ce 2.6.1
Yesterday i run yum update.

hehe, I’ll bet you are using the new trixbox bulk import/export. See July 10th, 2008 sasargen posting above. Since Fontality decided to fork FreePBX and start making changes that is one of them. Confusing, and they are the ones causing it.

If you wish to use the Fontality version you’ll need to goto the ww.trixbox.org site for support as it was not written by anybody here. If you want the one that is more robust and talked about as a FreePBX module please see the directions above on loading that one (probably the one you were following the directions for).

i am using Bulk Extensions module from tools, Third Party Addon.
Bulk extensions in trixbox are in PBX->bulk extensions.

volk22,

I have duplicated the error you found. It does not occur with standard FreePBX, but it looks like the wrapper trixbox puts around FreePBX is breaking the technique used to stream the csv file to your browser. I am investigating this further, but there is a workaround you can use in the meantime. The error causes the module to print the csv file to your browser window instead of a new file. You can copy all the text after the line that ends with “on line 290” and paste it into a csv file. This should be the same as the file output produced with standard FreePBX.

Thanks, Seth

volk22,

Some systems are having an error on a trailing new line in the functions.inc.php file for bulkextensions. The following fix has been tested on trixbox 2.6.1.1 using the virtual machine from Fonality:

[list]
[]log into trixbox console as root and type the following command line:
[
]nano /var/www/html/admin/modules/bulkextensions/functions.inc.php
[]when nano opens, press Alt + g
[
]when the prompt says Enter line number, column number: then type 308 and press enter
[]your cursor should be on a blank line at the bottom of the file. press Delete on your keyboard
[
]press Ctrl + x, then y, then Enter to exit, save changes, and overwrite the existing file
[/list]

Now go back to Bulk Extensions in the web interface and try the Export command.

Thanks, Seth

This problem is fixed with the new version of bulkextensions. Download version 0.2.1 at:

http://freepbx.org/trac/browser/contributed_modules/release/bulkextensions-0.2.1.tgz

Thanks, Seth

Hey guys, running either the latest 0.2.1 or 0.2.0 with the latest version of Trixbox I run into an issue where if I create a csv file with one entry it adds/deletes/changes without issue, but if I add more then one it succeeds on the first then dies. It displays no information on the screen and after a loooong time it will time out.

Any ideas as to what might be causing that?

Let me know if there is any information I can send your way to assist in figuring this out. I’d REALLY prefer not to do all this by hand :slight_smile:

Thanks again,

Iskondi

Iskondi, try exporting your extensions to csv with 0.2.1, then re-importing the csv without making any changes to it. If this fails, please post the contents of the csv file.

Thanks, Seth

I cleared out all my data, created two extensions inside the Web Interface exported that, added to it and reimported without issue!

Thanks!

Iskondi

Will the bulk extensions module be upgraded to be compatible with FreePBX 2.5?

We anticipate releasing it sometime next week after OTTS.