FreePBX | Register | Issues | Wiki | Portal | Support

Boot system !amportal is deprecated. Please use fwconsole!


(Javier Pastor) #1

As I indicated in the matter, to start the system during this household appears " !!!amportal is deprecated. Please use fwconsole!!!".
From time starts well, but in the future with any upgrade may fail.
Does anyone know how to fix it?


(TheJames) #2

Use fwconsole start


#3

That is likely caused by your “/etc/rc.local” file being outdated. just change amportal to fwconsole.


(Javier Pastor) #4

Hi thanks for the answer but is not that. I’ve looked at rc.local and right.
There has to be some other system boot script but can not find.

rc.local

!/bin/sh
touch /var/lock/subsys/local
/usr/sbin/fwconsole start


(Javier Pastor) #5

OK, Solved.
The problem was not “/etc/rc.local” was in “/etc/rc.d/rc.local”.
Thank you for bustra help.


(Thomas Hammel) #6

Great so now I have the right directory but how do you update the boot script.

Lots of info missing here for Noobs. Not very helpful at all!


#7

Everything you need is spelled out in this post.

If you don’t even know how to use a text editor, then what are you doing with a phone system that runs on CentOS and is exposed to the Internet?

Learn basic Linux or pay the price later. There are thousands of hackers out there just waiting for a guy like you to run a phone system. Good luck.


(Thomas Hammel) #8

Great now we have trolls in a support forum thanks for the support.

FYI My system is not yet production and not exposed to the net.


#9

This ain’t that simple! At least on CentOS

/etc/rc.local

is a symlink to

/etc/rc.d/rc.local

My /etc/rc.d/rc.local is dated from 2013 and my /etc/rc.local - WHICH IS A FILE - is dated from this morning when I ran the update script, so the update script obviously touches /etc/rc.local. I can’t say if the update script broke the symlink or not - I won’t know until the next time I run an update script - but with a broken symlink /etc/rc.d/rc.local is left in a stale state.

I moved /etc/rc.local into /etc/rc.d/rc.local and then reestablished the symlink with ln -s /etc/rc.d/rc.local /etc/rc.local, so this problem is resolved for now anyway.