BLF on Sangoma 500 lit when extension is idle


(John Potter) #1

Hi,

My setup is FreePBX 13.0.190.19, Asterisk 13.14.0, 2x Sangoma S500 phones with Firmware 2.0.4.0

I’m testing a couple of Sangoma S500 phones on a test FreePBX system and am having problems getting the BLF feature working properly.

I’ve configured a BLF on one extension to monitor the other extension.

The issue I’m having is that BLF light is on solid green even when the other extension is idle. I’ve run ‘show core hints’ in the Asterisk CLI and it confirms that the status of the extension is idle and that it is being watched. I would have thought that when the extension is idle the BLF light would be off. Is this correct ?

I know that the BLF is monitoring the other extension as when the other extension makes a call the BLF turns solid red for the duration of the call and when the call is ended the BLF status returns to solid green.

Is a solid green BLF indicator is the the correct status for an idle phone ? and also is there is a configuration parameter I can change to turn it off if teh extension is idle ?

Any help would be greatly appreciated.


(Tony Lewis - https://bit.ly/2SbDAyc) #2

Our BLFs is green when idle, red when in use and blinking red when ringing.


(John Potter) #3

That would explain it and in that case it’s working perfectly.

Is it possible to somehow change this behaviour on the Sangoma S500 to the more traditional Asterisk approach of extension idle=LED off, extension is ringing=LED Blinking and extension connected/busy=LED on ?

I want to put 3 or 4 BLFs on each phone and ideally don’t want it lit up like a christmas tree when all extensions are idle.

Any help on how the achieve this would be appreciated.


(Tony Lewis - https://bit.ly/2SbDAyc) #4

No that is not possible and almost all phones now days are green for idle and red for busy. Early SIP phones only has 1 color being red and off was idle and on was res but most modern phones now are red and green BLF.


(John Potter) #5

OK.

and thank you for such a quick response.


(MarkC) #6

Just wanted to +1 this request and to add that we have had multiple clients also prefer not having lots of green lights always ON. (It doesn’t take many LED’s to light up a dark’ish room!)

I also like the BLF light behavior where Idle = LED off vs. the Sangoma phone default where Idle = LED GREEN.
A quick simple feature could be something like a “BLF Idle = OFF” on the EPM Template Options page.

I will look into how to submit a feature request for this. It seems this option could be added in a future update and believe it would be an excellent and welcome feature.


(Steve ) #7

On the flip side of this I have just added an new extension and added a BLF for this extension on the rest of my phones. For some reason the other phones won’t show a green light for this extension If I press the BLF (which is dark) it makes an intercom call which is fine but I can’t get a light to show up green when it is in idle. Any ideas??


(system) closed #8

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.