FreePBX | Register | Issues | Wiki | Portal | Support

Blacklist not stopping spammers

configuration
Tags: #<Tag:0x00007fcd2e51ab00>

#1

I recently ported several DIDs to Sip Station. My old provider just sent a 10 digit inbound caller ID number and the blacklist was catching all the calls. Now Sip Station sends all of my inbound calls as 11 digit numbers, a 1 prepending the 10 digit number seems to be the suspect. What would be best way to address this issue? I know I can go in to mysql and write an update to prepend a 1 to all the blacklist items but there must be a better way to handle this.


(Marbled) #2

Hi!

I don’t currently have access to my PBX and I don’t use SipStation (which I think has special handling in FreePBX) but for a normal trunk you would set your context to from-pstn-e164-us to remove this.

See

If you have access to the trunk information for SipStation then set its context from-pstn-e164-us. If you don’t then please check for an option that let’s you change the format in which it return the caller ID.

It’s not suspect, it is just passing it in a different format, e164…

Re:

That “1” actually means it is coming from NANPA territory (ie, Canada, US, etc…), see

Good luck and have a nice day!

Nick


#3

Thank you! I got that all straightened out now.