FreePBX | Register | Issues | Wiki | Portal | Support

Bandwidth.com trunks and FreePBX


(Andrew Beauchamp) #1

I’m having some trouble getting Bandwidth.com peer trunks to work in my FreePBX setup.

Keep ending up with no-way audio. Can I get a couple examples of trunk settings for sip.conf from those that have their trunks set up properly with them?

Also, I might have in narrowed down to either NAT (RTP) issues or possibly progressinband or prematureaudio settings.

Any tips, tricks, suggestions, or things to be wary of when setting up Bandwidth trunks in FreePBX?

FYI, I have been using Vitelity and am migrating most of my DIDs to Bandwidth.com. Not having the same issues with Vitelity, so maybe someone with experience with both might know what is different between the two.


(Bradley Lauk) #2

Any luck on this? I’m having basically the same issue with bandwidth’s trunking!


(Andrew Beauchamp) #3

I have the config up and running without issue now. It was a couple of weird settings I had to apply in my SonicWALL. You aren’t using a SonicWALL are you? If you PM me more details I can assist.

For the sake of this thread, here is what I had to do:

  1. In my outbound NAT policy, I had to change the ‘original service’ from my SIP+RTP group to “Any.” Basically sending any/all traffic from the PBX out of the public IP address I was NAT’ing to, not just SIP/RTP. Something to do with the randomized port not being in the 10000-20000 range.

  2. In ‘advanced’ under that same NAT policy, I had to check ‘disable source port remap.’

So far, this has fixed my issue on every occaision. Some of my SonicWALLs didn’t have those options, but updating to the newest firmware makes them show up and configuring as above fixes it.


(Howard) #4

I have PFsense running at home, and trying to use Bandwidth from here causes issues. Anyone found out the trick to a working PFsense config with Bandwidth?

I have a static IP, but only one, so need to remap ports from inside/outside…

Your SonicWall info is great, I will have to see if any of that translates to PFsense at all…


(Bradley Lauk) #5

Andrew, would you be willing to provide what settings you’re using for your inbound/outbound trunks and for your user context are you using just your nine digit DID or are you using +1(nine digits)?

I’m feeling pretty stupid because I’ve been thrashing at these trunks for a couple days with little forward momentum. It’s connecting outbound, but won’t complete calls, and they can’t see my box from the outside. Frustrating.

EDIT: Not behind a sonicwall, not behind anything, actually. We’ve got a box with dual NICs that connects straight to the outside world and the other to the network. They’re a SMB and it was the easiest way to get them set up.


(Tom Ray) #6

@internetlad Are these straight up peers to Bandwidth or through their Catapult service?


(Bradley Lauk) #7

Straight through Bandwidth. I’ve got all the information and to the best of my ability I’ve set it all up but I’m still having issues.


(Tom Ray) #8

@internetlad Then this is just a pure, straight up trunk configuration. Nothing special to it. Bandwidth, unlike Vitelity, doesn’t do REGISTER for location services. They want IPs to send the calls to and IPs to expect calls from, that’s it. This needs to be a type=peer if this is Chan_SIP and a “No Registration” thing if Chan_PJSIP.

But if you are behind NAT and getting one way audio, then this is a firewall/NAT issue in your network. This level of service from Bandwidth is generally “provider” level and they don’t expect this to be behind NAT. Because 99% of providers are not behind NAT.


(Bradley Lauk) #9

Is there a resource you could recommend I look over that details a trunk configuration like this? Everything I’ve found is either for a different provider or woefully outdated. The documentation on the wiki seems to mostly only reveal information regarding SipStation and not what you would have to do for other providers.

Maybe this is a basic/stupid question, but I’m still pretty new to VOIP and telephony. I’ve got a good grasp on managing the actual systems themselves, but trunking is where i’m falling flat.

Thanks for the help.


(Tom Ray) #10

It’s not different than any other trunk setting in the samples or Wiki.

Set the host to the Bandwidth IP, set the trunk to normal settings and make sure nat=no because NAT is expressly assumed.

But again, if you are behind NAT, then this is issues with your network. Are you behind NAT? Are you having the same one-way audio issues?


(Bradley Lauk) #11

Unless I’m clueless about it, I’m not. Like I said we’ve got one nic directly out to our static IP, no hardware in between. The issue is that the calls aren’t completing on the trunk outbound and nothing is connecting inbound. I can’t imagine what the issue would be if there’s not something special to Bandwidth’s service, but I’ll check everything over again to make sure i’s and t’s are dotted and crossed.


(Tom Ray) #12

Show your trunk config


(Bradley Lauk) #13

I’ll post it in later tonight, I don’t have access to it currently.

I appreciate the assistance.


(Bradley Lauk) #14

Tom:

Got it figured out! you were right, it was FAR simpler than I was making it out to be. All I needed was the user=ip, type=peer and nat=no in the outgoing and nothing in the incoming.

Thank you! This has been killing me for days now.