Backup issue with Voicemail settings

I’ve noticed something strange when I do a backup. Here’s an overview of what I’m doing.

I have a main FreePBX and a backup FreePBX. I have the same postfix settings in both files on the main and backup PBX’s with the relayhost, sasl_auth_enable and so forth. I ran a test backup on the main PBX that pulled only the CDR server from the backup PBX. I went back to my file and all my settings I added in there are gone.

relayhost = [emailservergoeshere]:25
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_use_tls = yes
smtp_tls_security_level = encrypt
smtp_tls_note_starttls_offer = yes


smtp_tls_security_level = encrypt
smtp_tls_note_starttls_offer = yes

Version of FreePBX being used: 6.12.65-30

Am I missing anything that’s causing the file to be overwritten?

Can’t test it out much right now but I do see ( in one of my FULL Backups ) a: /var/www/html/admin/modules/sysadmin/hooks/config-postfix file… I ran it ( maybe a bad idea ) on my pbx system and it reset my /etc/postfix/ file and removed my sasl_passwd password stuff.

One way to ‘test’ if this is really an issue would be to remove that from a FULL backup ( maybe have to replace it with a dummy file) and do a restore and see if it fixes the issue… or do a restore and see if the config-postfix file is mentioned in any of the logs.


Tried that and no luck. Kept changing the file. I was able to get it stop changing with a chattr command but it’s not the perfect solution. I would like to know why it keeps getting changed on me every time a backup is done.

I think you might be missing my point… maybe…

This file IS in my backup: /var/www/html/admin/modules/sysadmin/hooks/config-postfix

That file DOES reset the file.

I’m thinking that maybe it gets run as part of the restore and that is WHY the file is getting reset.

If that’s the case… I think that would be a bug.


I excluded that file in my backup and tried a backup with only the CDR’s and my file is still changing. Does the file follow some format that gets checked every time a backup is done possibly for proper coding? That’s the only other possibility otherwise I think it may be a bug.


Any update on that?

Thank you,

Daniel Friedman
Trixton LTD.

Hi Daniel,

      I locked the file using chattr +i filename. This resolved my issue.