Backup from one Freepbx wont restore on another?


I have FreePBX running with a digium asterisk card. I am looking to run some tests, so i made a VM, installed Freepbx 64 bit (6.12.65.iso). I run a backup on Server #1 which goes to my local FTP (I can see the data there). I try to restore but it keeps saying the upload failed. The backup file is about 300mb.

I am unable to restore the file to Server #2 but it keeps failing. Any ideas what could be causing the problem?


Are the two machines on the same level? Was the old one also a 64 bit?

I believe they are both 64 bit - how would i check for sure?

What is the default location for backups? I can use SFTP to manually move the backup data file to the new server - or at least try.

use the command “arch”. If it says i686 it’s 32 bit, if it’s 64 bit it will say that explicitly. Anyone know of a good way to change a 32 bit system to 64 bit? Assuming that the backup / restore wont work across them.

32 bit

64 bit

If you’re storing backups locally it goes to /var/spool/asterisk/backup/

I have restored 32bit backups to 64bit fresh installs before, though not without problems with the cdrs.


Both boxes say x86_64 when using the arch command. I dont have the /var/spool/asterisk/backup/ directory. Should I just make the backup directory manually?

If i use the gui to backup, it says i have one but i cant find it when using sftp.


/var/lib/asterisk/backups is where I find mine if I tick legacy storage

You might want to change some php.ini settings. The default upload file size limit is 20 megs. Here’s the settings I found work with larger systems:
upload_max_filesize = 100M (defaults to 20)
max_execution_time = 300 (defaults to 30)
max_input_time = 600 (defaults to 60)
memory_limit = 1024M (defaults to 512M)

or you could SCP the backup file to the default local server location /var/spool/asterisk/backup/, then it will show up in restore when you select local server and there will be no upload.

Opps! Just noticed your backup file is 300MB?! You must have your CDR file in there. Adjust php.ini upload_max_filesize = 400M

I have not been able to upload a backup file via the http page or from an ftp server. I have to ftp it in to a local directory and then select it from the wizard.

Also, ftp may be messing with permissions or using the wrong type of transfer and corrupting it on your server. Can you open the tar file after uploading to verify? I would just ftp/sc it directly from one server to another (which is what i do). Then chmod 777 it if you still have issues.

@hecatae, what specific issue have you seen with regard to CDRs?

I’m not sure if this is a new variation on this theme:
I have FPBX working on one (old) server.
New install on another (new) computer has updated to

Using the backup from the old computer (.tgz) I browse for that and upload it to the Restore page of the GUI from a local folder.
Then I hit restore, and nothing happens (on the gui, anyway)
This technique has always worked before.

Is the problem the different version of FPBX? If so, how do I downgrade to so they match?

Possibly unrelated: This failure to restore happened just after doing this:

fwconsole ma upgrade dashboard

Once done, run

fwconsole reload

to deal with Admin GUI Dashboard Error after module update today


Any help with the Restore issue much appreciated.

Copy that backup file to the /backup folder in the PBX, then restore.

I cannot find the backup folder anywhere. And when I ran a backup, hoping that would create one, i get:
No storage servers found. Aborting.

Can I create a backup folder for this to work? I’m using Filezilla to access the PBX files.

THanks for your help

are you saying that /var/spool/asterisk/backup does not exist?

If you are correct, you need to setup at least one backup perhaps called “first-time” and run it in the new machine, this is a good thing as it will save you any amount of time if the restore of external data fails , just restore the “first-time” backup

(then copy your .tgz into an identifiable by you directory under /var/spool/asterisk/backup/ with the correct permissions, FreePBX will find it, and restore at your command)

You did not select local storage in your backup job

OK. Thanks.
Have fixed that and now can find the backup folder in var/spool/asterisk.
But Restore still does not work
It just times out.
Whether I use the backup from my old system, or the backup I just made from this server.

I guess next step is to re-load FreePBX.

Any suggestions before I do that?

Yes, make sure you have the exact version of FreePBX. The version 6.12.65 is FreePBX 12!! You’re going backwards from this as 12.0.x is FreePBX 14.

So basically you have setup a machine running SNG7/FreePBX 14 and then set up a server with FreePBX 12 /Distro 5(?). Now you’re trying to restore a machine across version, which is not allowed to being with, but you’re taking a current version and trying to restore to a 5 year+ old version that can’t support it.

Slight correction, it may be FreePBX 12 but it’s possible the FreePBX was upgraded and the OS wasn’t. The framework version will tell you the definitive FreePBX version.

That may be, but only applies between the 2 different systems.
When I tried restoring from the backup on the same (new) server, it still wouldn’t run the restore.

Will reload FreePBX and see if it fixes it.