Backup and Restore Module reporting file store error

Been running FreePBX 17 more or less since it was announcing but I have an issue suddenly. I had a daily backup job setup to use SSH to transfer the config to my NAS but now when I open Backup and Restore I immediately get a toast message ‘Undefined Array Key “enabled”’ and points to Filestore.class.php. I tried deleting and recreating both my Filestore SSH server and the Backup job but I can’t select any destination in the job. Not even local is an option. Has anyone else seen this?

Never mind, I resolved it myself. It seems to be an issue with Filestore module version I ran ‘fwconsole ma downloadinstall filestore tag=’ to go back one version and all is fixed. Interestingly it seems that my backups were still running, I just couldn’t see the files through the Restore tab because of the issue with the Filestore module.

Hopefully this helps someone else.

Hi @SonicJoe just fyi - issue has been fixed in the latest edge release of filestore module.

How does one enable the edge repo? I am seeing similar issue with the filestore module

fwconsole ma downloadinstall backup --edge

I tried that and am still getting fwconsole errors:

root@phones:~# fwconsole ma downloadinstall backup --edge
Edge repository temporarily enabled
No repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings

Downloading module 'backup'
Processing backup
Verifying local module download...Verified
Download completed in 4 seconds
Detected Missing Dependency of: filestore 17.0.1
Found local Dependency of: filestore
Installing Missing Dependency of: filestore 17.0.1
Resetting temporarily repository state

In Filestore.class.php line 52:

  Undefined array key "enabled"

I’ve had issues upgrading to Filestore now. It fails to install and causes the web GUI to go to a debug console. has been stable for me and I am holding there until I see additional updates. Do “fwconsole ma downloadinstall filestore --tag=”. No need to use Edge.

Hi @SonicJoe Can you please try with below release ? thanks

fwconsole ma downloadinstall filestore --tag=

Thanks! does appear to be working so far. I will report back if any issues.

Hmm, I should check this since I am testing the beta…I don’t check my backups a alot, I should be checking more during the FreePBX 17 beta.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.